View Full Version : Taking forever to boot (quotas? I didn't enable...)

11th September 2006, 08:45 PM
My system must think disk quotas are enabled, even though they aren't. When I reboot, the system stops at "Enabling local filesystem quotas:" for hours. :confused:

EDIT: I found out why it's so slow. It's trying to delete 80 gigs worth of links from my temp folder! I can only imagine how many files that is. I think they were caused by qemu but I'm not sure since I can't access the folder to view them (too many files).

As a workaround for the hang at boot, I booted rescue CD and commented out the quotaon from rc.sysinit until I understand what's going on. At least it boots now.

if [ -x /sbin/quotaon ]; then
# action $"Enabling local filesystem quotas: " /sbin/quotaon -aug
fiI can use the computer but sooner or later I'm gonna hafta remove these temp files and it's going to take many hours.

12th September 2006, 05:43 AM
you can get rid of files and directories in /tmp
what FS do yo have ? ext3 .. reiser?

anyway, id say boot from rescue to do this, mount partition
do: <after chroot <whatever>>
cd /tmp
rm -rf *;rm -rf .*

if there's really that many files, this will take a while, it most likely isn't freezing but it will take a long time just do the command and let it go for an hour or something ..
although .. not sure why your tmp would be so big, mine will get up to 5 gb every so often, but ill check it every week or two and delete all of it; id say just stay on top of it.

umm run fsck on you partitions .. LVM makes fsck much harder to do, for that boot with argument: single and unmount partitions (you need to unmount ext3)
if ext3:
fsck.ext3 -fp <device> and do that for each partition

if reiser .. i can't tell you a whole lot here

it would be reiserfsck --check <device>
then reiserfsck --fix-fixable <device>
reiserfsck --rebuild-sb <device>
reiserfsck --rebuild-tree <device>
reiserfsck --clean-attributes <device>

.. but idk i prefer ext3 .. im pretty sure reiserfsck doesn't support combining all 5 of those options into one command

12th September 2006, 08:16 AM
I'm using LVM of ext3 partitions (default FC install). I found a shortcut to deleting huge directories after letting rm -rf run for many hours (so many tiny files) and only getting 2-3 gigs back, I finally got mad, :mad: rebooted to rescue CD, ran debugfs and cleared the inode for the directory with clri /tmp/kde-sexyuser01 :eek: then I unmounted the drive and ran fsck -fn > /dev/null (to speed things up without the message scrolling of deleted inodes) only took a few min to reclaim 80 gigs of small (< 1k) files. :p

I'm not sure what program creaed all those small temp files. I think they may have been redundant or recursive links pointing to eachother. I let a few slip into /lost+found and examined the contents and they all consisted of 9 bytes of the same character string, "? ^A". Weirrrrd. :confused:

My /tmp is under scrutiny now: watch -n 10 "du /tmp | sort -gr"

Thanks for the response though :D