PDA

View Full Version : Audacity: "There was an error initializing the audio i/o layer.'



xeonman9000
11th September 2006, 04:54 PM
Hello, I just installed Audacity on my Fedora Core 5 x86_64 machine using the command "yum install audacity" and the Livna repository. However, when I try to run Audacity, I get the following error message popping up.

"There was an error initializing the audio i/o layer.
You will not be able to play or record audio

Error: Host error."

Audacity then continues to open up, but I can't use it.
I searched this forum the Audacity forum for a cure and it seemed to suggest I was missing something called oss-alsa, so I tried "yum install oss-alsa" and varients thereof, but there was not match to oss-alsa, aoss, etc.
Can anyone please help me? My soundcard is a C-media and the Kinfocentre kicked out the following information for it:

http://www.fedoraforum.org/forum/attachment.php?attachmentid=9023&stc=1

daneel971
11th September 2006, 05:08 PM
set the audacity audio device to /dev/dsp and be sure to kill the sound server before strating audacity (artsd for kde; esd - not sure - for gnome).

xeonman9000
11th September 2006, 05:13 PM
I opened up the "Audio I/O" panel in the preferences menu, but there were no devices in either the input or output drop down menus. Is this what you meant?

daneel971
11th September 2006, 05:14 PM
yep. But first close audacity, kill the sound server and then re-open audacity.

xeonman9000
11th September 2006, 06:00 PM
Sorry, but could you give a bit more of a detailed description of how to "kill the sound server"? I'm using KDE.

LocutusOfBorg
11th September 2006, 06:03 PM
open a terminal and type

killall artsd
and you're done.

xeonman9000
11th September 2006, 07:00 PM
I did that and there are still no devices in the preferences window.

daneel971
11th September 2006, 07:17 PM
Sorry, no other ideas. I'm using a CVS version compiled with portaudio v19 and it works fine.
Try reading this, I hope you will find something useful (I saw that you posted on the audacity wiki, so maybe you already know about this...).