PDA

View Full Version : Help, "yum install vlc"



Fedoration
10th September 2006, 07:34 PM
Hi, I'm sorry if this is a stupid question. But this linux crap is more like one of those point and click adventure games (like monkey island) than it is an operating system. In other words, I'm stuck and I need the walkthrough.

I'm running fedora 5. I don't know what else you should know. Em, I have installed "a52dec" but still it shows up as missing dependency. And the rest I have no idea where or how to get.

I followed the instructions on http://www.videolan.org/vlc/download-fedora.html. I ran yum install vlc and that didn't work. So I tried installing just the base, disabling all files but vlc.repo. Still don't work.
Please help.

This is what the terminal says:


# yum install vlc
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
core [1/5]
vlc [2/5]
updates [3/5]
fedora-as [4/5]
extras [5/5]
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package vlc.i386 0:0.8.5-1 set to be updated
--> Running transaction check
--> Processing Dependency: libfribidi0 for package: vlc
--> Processing Dependency: libdvbpsi.so.3 for package: vlc
--> Processing Dependency: libslang-utf8.so.1 for package: vlc
--> Processing Dependency: libdvbpsi3 >= 0.1.3 for package: vlc
--> Processing Dependency: libdvdnav.so.4 for package: vlc
--> Processing Dependency: libwx_gtk2u_core-2.6.so.0(WXU_2.6.2) for package: vlc--> Processing Dependency: libmad >= 0.15.0b for package: vlc
--> Processing Dependency: libfaad.so.0 for package: vlc
--> Processing Dependency: libwx_baseu_xml-2.6.so.0 for package: vlc
--> Processing Dependency: libgnutls.so.11(GNUTLS_REL_1_0_9) for package: vlc
--> Processing Dependency: libwx_gtk2u_core-2.6.so.0(WXU_2.6) for package: vlc
--> Processing Dependency: libwx_baseu_net-2.6.so.0 for package: vlc
--> Processing Dependency: libwx_gtk2u_adv-2.6.so.0(WXU_2.6) for package: vlc
--> Processing Dependency: libwx_baseu-2.6.so.0 for package: vlc
--> Processing Dependency: libwx_gtk2u_html-2.6.so.0 for package: vlc
--> Processing Dependency: libwx_gtk2u_core-2.6.so.0 for package: vlc
--> Processing Dependency: libid3tag.so.0 for package: vlc
--> Processing Dependency: libdirac_encoder.so.0 for package: vlc
--> Processing Dependency: libwx_gtk2u_xrc-2.6.so.0 for package: vlc
--> Processing Dependency: a52dec for package: vlc
--> Processing Dependency: wxGTK >= 2.4.2 for package: vlc
--> Processing Dependency: libdbus-1.so.1 for package: vlc
--> Processing Dependency: libartsc.so.0 for package: vlc
--> Processing Dependency: libmad.so.0 for package: vlc
--> Processing Dependency: libfribidi.so.0 for package: vlc
--> Processing Dependency: libgnutls.so.11 for package: vlc
--> Processing Dependency: arts for package: vlc
--> Processing Dependency: libwx_gtk2u_adv-2.6.so.0 for package: vlc
--> Processing Dependency: libdirac_decoder.so.0 for package: vlc
--> Processing Dependency: libwx_baseu-2.6.so.0(WXU_2.6) for package: vlc
--> Processing Dependency: libwx_gtk2u_qa-2.6.so.0 for package: vlc
--> Processing Dependency: libdvdcss >= 1.2.8 for package: vlc
--> Processing Dependency: libtwolame.so.0 for package: vlc
--> Processing Dependency: libmp4v2.so.0 for package: vlc
--> Processing Dependency: libSDL_image-1.2.so.0 for package: vlc
--> Processing Dependency: libmpcdec.so.3 for package: vlc
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package fribidi.i386 0:0.10.4-8.2.1 set to be updated
---> Package SDL_image.i386 0:1.2.4-5.fc5 set to be updated
---> Package compat-slang.i386 0:1.4.9-27.2.1 set to be updated
---> Package libid3tag.i386 0:0.15.1b-2.fc5 set to be updated
---> Package wxGTK.i386 0:2.6.3-2.6.3.2.2.fc5 set to be updated
---> Package libmpcdec.i386 0:1.2.2-2.fc5 set to be updated
---> Package arts.i386 8:1.5.4-0.1.fc5 set to be updated
--> Running transaction check
--> Processing Dependency: libfaad.so.0 for package: vlc
--> Processing Dependency: libfribidi0 for package: vlc
--> Processing Dependency: libdvbpsi.so.3 for package: vlc
--> Processing Dependency: libdvbpsi3 >= 0.1.3 for package: vlc
--> Processing Dependency: libdvdnav.so.4 for package: vlc
--> Processing Dependency: libmad >= 0.15.0b for package: vlc
--> Processing Dependency: libdvdcss >= 1.2.8 for package: vlc
--> Processing Dependency: libdirac_encoder.so.0 for package: vlc
--> Processing Dependency: libtwolame.so.0 for package: vlc
--> Processing Dependency: libgnutls.so.11 for package: vlc
--> Processing Dependency: a52dec for package: vlc
--> Processing Dependency: libmp4v2.so.0 for package: vlc
--> Processing Dependency: libdbus-1.so.1 for package: vlc
--> Processing Dependency: libgnutls.so.11(GNUTLS_REL_1_0_9) for package: vlc
--> Processing Dependency: libdirac_decoder.so.0 for package: vlc
--> Processing Dependency: libmad.so.0 for package: vlc
--> Finished Dependency Resolution
Error: Missing Dependency: libfribidi0 is needed by package vlc
Error: Missing Dependency: libdvbpsi.so.3 is needed by package vlc
Error: Missing Dependency: libdvbpsi3 >= 0.1.3 is needed by package vlc
Error: Missing Dependency: libdvdnav.so.4 is needed by package vlc
Error: Missing Dependency: libmad >= 0.15.0b is needed by package vlc
Error: Missing Dependency: libfaad.so.0 is needed by package vlc
Error: Missing Dependency: libgnutls.so.11(GNUTLS_REL_1_0_9) is needed by package vlc
Error: Missing Dependency: libdirac_encoder.so.0 is needed by package vlc
Error: Missing Dependency: a52dec is needed by package vlc
Error: Missing Dependency: libdbus-1.so.1 is needed by package vlc
Error: Missing Dependency: libmad.so.0 is needed by package vlc
Error: Missing Dependency: libgnutls.so.11 is needed by package vlc
Error: Missing Dependency: libdirac_decoder.so.0 is needed by package vlc
Error: Missing Dependency: libdvdcss >= 1.2.8 is needed by package vlc
Error: Missing Dependency: libtwolame.so.0 is needed by package vlc
Error: Missing Dependency: libmp4v2.so.0 is needed by package vlc

markkuk
10th September 2006, 10:28 PM
I'm running fedora 5.
(...)
I followed the instructions on http://www.videolan.org/vlc/download-fedora.html.

The top of that page says in large font that the packages are for Fedora Core 4, not 5.
You can get VLC for FC5 from the Livna (http://rpm.livna.org/) repository.