PDA

View Full Version : Help with QT



phi16181
9th September 2006, 03:28 PM
I am trying to compile superkaramba and each time that I try the ./configure I get the following error:

Qt (>= Qt 3.0) (headers and libraries) not found.

I have installed and updated the qtdevel and lib packages and I have a working directory in /usr/lib/qt-3.3.

What could be giving me this error and what is the resolution to it?

thanks in advance

rclark
9th September 2006, 11:02 PM
Have you setup your QTDIR variable?

mine shows

[root@home hello]# echo $QTDIR
/usr/lib/qt-3.3
[root@home hello]#

phi16181
10th September 2006, 12:22 AM
How do I go about doing that? When I echo it it doesnt return anything...

[maTa]
10th September 2006, 12:23 AM
export QTDIR=/usr/lib/qt-3.3

rclark
10th September 2006, 02:29 AM
maTa has it right. Do that from the command line if you only expect to use it 'once'. Otherwise I'd put it in a startup script somewhere so that it is always 'setup' . Even put it in your .bash_profile file....