PDA

View Full Version : FC4 Kernel errors with DVD or CD (2.6.17-1.2142_FC4)



alt_ctrl_del
9th September 2006, 05:05 AM
Anytime I put a CD or DVD into my mythtv 0.19 DVD drive, I start getting errors written to /var/log/messages.

(/var/log/messages)
Sep 3 16:48:08 localhost kernel: hda: packet command error: error=0x54 { AbortedCommand LastFailedSense=0x05 }
Sep 3 16:48:08 localhost kernel: ide: failed opcode was: unknown
Sep 3 16:48:09 localhost kernel: hda: packet command error: status=0x51 { DriveReady SeekComplete Error }

For a CD, these errors repeat 8 to 10 times and then stop. But, for a DVD they are continuous. My system boot loads the Uniform CD-ROM driver.

(dmesg)
Probing IDE interface ide0...
hda: _NEC DVD_RW ND-3550A, ATAPI CD/DVD-ROM drive
hda: ATAPI 48X DVD-ROM DVD-R CD-R/RW drive, 2048kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20

I have also tried a different DVD drive (and cable), but get the same errors. I have also tried messing around with the mount options in /etc/fstab to no avail.

(/etc/fstab)
# This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/1 / ext3 defaults 1 1
/dev/devpts /dev/pts devpts gid=5,mode=620 0 0
/dev/shm /dev/shm tmpfs defaults 0 0
/dev/proc /proc proc defaults 0 0
/dev/sys /sys sysfs defaults 0 0
LABEL=SWAP-sda3 swap swap defaults 0 0
/dev/mapper/vg0-videoLVM /video reiserfs defaults,noatime 1 2
#/dev/hda /media/cdrecorder auto pamconsole,exec,noauto,managed 0 0
/dev/hda /media/cdrecorder udf,iso9660 ro,user,noauto 0 0

I have scoured the forum archives and google. A couple of old goole hits, but none with problem resolution.
Can someone PLEASE (on my knees, begging) provide me some guidance with this?
TIA.

G.Fields