PDA

View Full Version : smp kernel-devel



blue_tacos
9th September 2006, 12:03 AM
Long story short, I tried getting into Linux and gave up and am revisting it now and things are slowly all starting to piece together :-) But I'm still having a few problems. I have absolutely no internet because my connection is wireless and Fedora doesn't detect it, so I've been trying to install ndiswrapper and madwifi. But everytime I try doing a make/make install I get a bunch of errors. I figured out thats because I don't have a link built between usr/src/kernel and lib/modules etc. So after lots of reading I figured out to build the link I needed too install the kernel-devel for my kernel version. Problem is I can't find the one for my version. I have 2.6.15-1.2054_FC5smp. I cannot find a kernel-devel with smp at the end. From reading I have figured out that smp is for dual processors or hyperthreading and yes I have that. When I install Fedora it doesn't even give me an option to not install the smp kernel. BASTARDS! Anyways if someone could point me to a link where I could download the proper kernel-devel I'd really appreciate it. Thanks

blue_tacos

blue_tacos
9th September 2006, 12:18 AM
FINALLY!!!! I found it. Now that I'm home and I'm using an uncapped cable modem once again instead of dial up it feels like I can fly once again.

http://download.fedora.redhat.com/pub/fedora/linux/core/5/i386/os/repodata/repoview/kernel-smp-devel-0-2.6.15-1.2054_FC5.html


If I'm wrong in my first post, someone please correct me.

marko
9th September 2006, 01:58 AM
You also could have just changed your kernel to one you did have
luck finding the devel rpm for:


yum remove 2.6.15-1.2054_FC5smp
yum install kernel-smp-2.6.17-1.2174_FC5 kernel-smp-devel-2.6.17-1.2174_FC5

then do the build.

You can also get yum to do the searching work for you:


yum search kernel-smp-devel* | grep 2054

will find all the kernel devel packages for smp, the grep filters it so the
output only shows you the 2054 related ones.

Mark

blue_tacos
9th September 2006, 11:48 PM
No can do. I don't have the internet, so no yum :-(. All I have available is wireless which I'm working on getting. Its a real pain in the ass to keep reseting every 30sec and going back to windows to download something new or read something else and try it. Over and over again. I can't count how many cdrs I've wasted on something thats 100kb. I need to get some rws.

edit: Just wondering how come Ubuntu can detect my wireless card but Fedora can't? kinda sad

marko
10th September 2006, 12:24 AM
I guess I don't understand this 30 seconds thing you're talking about, I thought you
said in post #2 that you found the devel package, now with that installed
why doesn't your wireless driver compile?
Mark

blue_tacos
10th September 2006, 01:12 AM
The 30 second thing I'm talking about is finding files I need for Linux using Windows then putting them on a cd and booting into Linux and going back and fourth because I have a dual boot system. Yes I found the devel package but its not installed yet. I don't go back home for another few days. Lets just hope in a few days my wireless driver will compile. I'll keep you updated. Thanks for the help! I appreciate it.

blue_tacos
11th September 2006, 05:23 AM
I give up on Linux, I've wasted too much of my life on it. When I try to install the kernel-smp-devel package it says "unable to retrieve software information." But for some f***** up reason it lets me install a devel package from a kernel version I don't even have. So I tried updating my kernel and it says successful but for some reason it only lets me boot into my older kernel version. I checked in the boot folder and the newer kernel isn't even in there only the older one which is 2.6.15-1.2054. Everything is messed up and I've already reinstalled the OS 4 times. Kinda frustrating :( I even went as far as to manually copy and paste all the folders in the right place so there was a link in lib/modules/mykernelversion. Everytime I try to run make in madwifi or ndiswrapper I get an error code 1 or 2 and it says only kernel versions above 2.4 are supported. If anyone can try to correct my ignorant ways down to the very basics and get madwifi running I'll paypal you $5.