PDA

View Full Version : beagled runs at high 100% cpu usage constantly on FC5?



jyap
8th September 2006, 11:58 PM
Running FC5 with the latest Beagle package from the default repositories.

$ uname -a
Linux primerib 2.6.17-1.2174_FC5smp #1 SMP Tue Aug 8 16:00:39 EDT 2006 i686 i686 i386 GNU/Linux
$ cat /etc/redhat-release
Fedora Core release 5 (Bordeaux)
$ rpm -q beagle
beagle-0.2.6-1.fc5.1

CPU usage is constantly at around 100%.

Any clues? Beagle's pretty handy except for this problem.

Dumbledore
10th November 2006, 05:57 AM
Run the command "gnome-system-monitor" as root. Go to the "View" tab and check "All processes". A program called "beagle-build-index" should be taking up a fairly high percentage of the CPU. Kill it. You should have no more problems for that session. Haven't figured out a long-term solution yet, sorry.

rhasselbaum
5th December 2006, 11:46 PM
Same problem here using FC6. The process I see taking 100% CPU is called "beagled" not "beagle-build-index". I can kill it, but would rather fix the problem.

Assuming the Beagle index is corrupt, is there a way to reset it?

u-noneinc-s
6th December 2006, 02:13 AM
Does it interfere with operation of the system? Is the system unresponsive because of this? Does the system still run fine ie, no delays in keystrokes or mouse clicks or even pointer motion?
I killed beagled on my FC5 because of this and the system was unresponsive, but I read that it is not a problem on fc6 as it is supposed to take advantage of "idle time", and release the CPU when needed by other apps.

jtang613
6th December 2006, 02:29 AM
Does it interfere with operation of the system? Is the system unresponsive because of this? Does the system still run fine ie, no delays in keystrokes or mouse clicks or even pointer motion?
I killed beagled on my FC5 because of this and the system was unresponsive, but I read that it is not a problem on fc6 as it is supposed to take advantage of "idle time", and release the CPU when needed by other apps.
I removed beagled because it constantly abused CPU idle time. Whenever I left my PC for more than a few minutes, beagled would take over, spinning both CPU and disk, and never completing whatever it was doing. It would run all night, and still not finish its task.

However, beagled would switch itself idle, when I began using my system - but that's not really my concern. No periodic deamon (such as beagled) should spin both CPU and disk 24/7 without interruption. It's unnecessary, it's annoying, and it smacks of a big bug.

m2c,
Jason

u-noneinc-s
6th December 2006, 02:40 AM
For me, locate is good enough. If I can't remember a filename (or even part of a filename) then I probably won't remember any relevant text string to search either. (Must be that CRS syndrome) ;)
I believe beagle is "supposed' to be very thorough in searches though finding any word (or search string) in any and all files on your system. (?)

rhasselbaum
6th December 2006, 03:47 PM
Does it interfere with operation of the system? Is the system unresponsive because of this? Does the system still run fine ie, no delays in keystrokes or mouse clicks or even pointer motion?

My FC6 system is still responsive. But I agree with Jason that this is beside the point. I can't think of a legit reason it should be running constantly. Plus, i sometimes run long build processes in the background with "nice" that will presumably compete with Beagle now. What's it doing?

u-noneinc-s
6th December 2006, 03:56 PM
I killed it before it ever completed because my sys was unresponsive so I never got the chance to use it, but I believe it is cataloging every file and quite possibly every word IN every file.

rhasselbaum
8th December 2006, 05:15 PM
There is extensive talk about this on Launchpad (Ubuntu):

https://launchpad.net/distros/ubuntu/+source/beagle/+bug/64326

Bottom line is that later versions of Beagle (>0.2.12) solve at least some problems related to high CPU usage. If there isn't a Fedora bug filed about this already, I'll enter one. Hopefully, Fedora repos can be updated sooner rather than later. :-/

andyschlei
10th December 2006, 05:06 AM
How do you stop it from running? It doesn't show up as a service and it is not in /etc/rc.d/init.d/

u-noneinc-s
10th December 2006, 05:14 AM
I'm not sure anymore since I removed it, but I think it should be in the service manager
system-config-services

andyschlei
10th December 2006, 05:20 AM
No, it is not there. I did find a daily cron job that must get picked up when the system catches up.

I just uninstalled it ('yum remove beagle'). I don't want a "total index" of my workspace. 'locate' works fine for me.

Trek1701
25th December 2006, 11:06 PM
No, it is not there. I did find a daily cron job that must get picked up when the system catches up.

I just uninstalled it ('yum remove beagle'). I don't want a "total index" of my workspace. 'locate' works fine for me.
Try this:

System > Preferences > More Preferences > Sessions

Go to tab "Start Programs", select "beagled --autostarted" and click disable.

On next boot beagled will not load for this user.

Trek1701

andyschlei
27th December 2006, 10:36 PM
Trek1701,

Thanks, this is very helpful. I didn't even know that dialog existed!

RupertPupkin
28th December 2006, 12:50 AM
I removed beagled because it constantly abused CPU idle time. Whenever I left my PC for more than a few minutes, beagled would take over, spinning both CPU and disk, and never completing whatever it was doing. It would run all night, and still not finish its task.

However, beagled would switch itself idle, when I began using my system - but that's not really my concern. No periodic deamon (such as beagled) should spin both CPU and disk 24/7 without interruption. It's unnecessary, it's annoying, and it smacks of a big bug.
Wait, you mean that an application (Beagle) that uses a Microsoft-created API (C#/.NET) was thrashing your system? I am shocked, shocked I say. :rolleyes: