PDA

View Full Version : Can't compile from tarball



John the train
8th September 2006, 11:09 AM
I'm attempting to install Gutenprint 5.0.0 ( formerly gimp-print ) to see if that solves my problem printing from gimp. However, when I unpacked the tarball and cd'd to the directory, bash reported ' command not found ' for ' config ', although it has a man page for it! I found a script ' comfigure ' in the directory, which did that bit, but when I tried ' make ', ' command not found ' again! As far as I can see from my references and what i've found on the forum I'm following standard procedure, and I've installed all the development packages from ' add/remove software '. Can anyone spot if I'm missing a package or doing something the wrong way? BTW, the Gutenprint tarball is the ' official ' version, not a release candidate. Thanks in advance guys. :confused:

ccrvic
8th September 2006, 11:37 AM
when I tried ' make ', ' command not found ' again!

Have you got the make RPM installed?

Vic.

John the train
8th September 2006, 03:05 PM
Hi Vic,
I've just run ' find make ', response ' no such file or directory ', but looking for ' make ' in Yumex it lists ' make ' in the remove list, implying it's installed. The version is given as 1:380-10.2, I've never seen a colon in a version number before, does that have any significance? I also think I may not have got the ' find ' command right, should it have been ' find / make '? I'll try that anyway. Thanks for the suggestion, I'll get back as soon as I've checked.

John the train
8th September 2006, 03:19 PM
Back again,
Running ' find / -name make ' found, among various ' permission denied ' ( I was running as user ), /usr/bin/make, from the properties it was installed as part of the clean re-install I did a few days ago. I'm still feeling my way in the file system and the command line, my Linux library consists of two beginners level ( Dummies and Easy Steps ) and a massive Unix tome which is a help, when I can a) find things and b) understand it!