PDA

View Full Version : glibc conflict



sardonyx
8th September 2006, 01:41 AM
Hi guys I'm trying to get a program to work on my system it says it needs SDL_mixer installed. Well that has a dependancy of "Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package SDL_mixer"

I downloaded glibc-2.4.90-29.i686.rpm and it's coming up with this crazy message I dont understand. I'm not sure where to go from here:



---> Package glibc.i386 0:2.3.6-3 set to be updated
--> Running transaction check
Error: glibc-common conflicts with glibc > 2.3.6
Error: Missing Dependency: glibc-common = 2.4.90-29 is needed by package glibc
Error: Unable to satisfy dependencies
Error: Package glibc-devel needs glibc = 2.3.6-3, this is not available.
Error: Package glibc-headers needs glibc = 2.3.6-3, this is not available.
Error: Package glibc-common needs glibc > 2.3.6, this is not available.
Error: Package glibc needs glibc-common = 2.4.90-29, this is not available.

markkuk
8th September 2006, 10:19 AM
You must update the glibc-devel, glibc-headers and glibc-common packages at the same time as glibc. Are you sure the packages you are trying to install are the right versions for your system? Which version of Fedora are you running? Glibc 2.4.90-29 is the version for FC6test/development (a.k.a Rawhide), you shouldn't try to install it in any earlier Fedora releases.