PDA

View Full Version : bad sound quality



tighe
7th September 2006, 09:22 PM
hi, i've switched to fedora core from windows a couple of days ago and love everything about it except the sound quality of mp3 and cd playback

i've tried to seach the topic, but everything i find has suggestions of the sort - improve bitrate or change to/from alsa, well that doesn't help at all, it's just the same distorted stuff i hear - like playing music 20 per cent above the max speaker output, only at all levels of volume. i've checked the soundblaster site, thinking about that it's time to maybe upgrade to a top level offering from them, as i'm using an internal intel device at the moment, but finding no linux drivers at the support page, the problem is likely to be solved somehow still at the current stage.

help! music is my love and i don't want to go back to microsoft! i also tried various players - it's the same, and having cd's sound terrible i assume it's some core issue. btw, movies sound Ok..

container
8th September 2006, 08:06 AM
I used to get this, too, when I used my motherboard's sound card. All I could do was to lower the volume in programs like alsamixer, because it really did seem to be on overdrive. I've since used quite an old sound blaster on PCI, without any trouble.

VictorienSardou
11th September 2006, 01:46 PM
Have you tried using a different Output Plugin other than alsa eg OSS Output Plugin?

red_dungeon
11th September 2006, 02:08 PM
@tighe

Seems that some/all volumes are too high. Or your mic input is on, and it get disorted by a loop.

So... try to change your mixer settings first. Mute/Unmute some channels.

kettu
11th September 2006, 06:55 PM
My money is on the PCM channel being maxed out. Double click the sound volume icon and turn PCM down to 90%. Now the volume can be set via the Master channel without distortion.