PDA

View Full Version : Fedora 5 CraSHED



neptune
6th September 2006, 07:05 PM
I set up fedora 5 on a intel board intel cpu it crashed the error message said "SE Linux targeted policy relabled"

Half the screen is white the rest is black, when it was loaded it worked fine until three days later it crashed with that messege.

schwim
6th September 2006, 08:15 PM
SELinux is designed for people who like the idea of self flagellation, but fear that visible marks on their body will cause problems at work.

I had more problems with it than I could count on my hands, even if I were to borrow your hands as well. My linux experience sans SELinux has been peachy comparatively.

The moral of this story is try an install without SELinux(NOT permissive). Ignore all of the people that come in after me to tell you that ninjas will steal your computer and molest your dog if you disable it.

thanks,
json

steelgrave
6th September 2006, 09:14 PM
It's true ninja's will steal your computer, but it's your neighbor molesting your dog.

Seriously schwim is right, SELinux is more of a PITA than it's worth. Unless you have something so secretive that space aliens can't know, I'd skip SELinux altogether.

marko
7th September 2006, 01:10 AM
If it's already installed, it's easy to turn off via editing this file:
/etc/selinux/config
to set SELINUX to disabled:

SELINUX=disabled

There might be some GUI control that edits that file
the same way but that's what I did.

Mark

pparks1
7th September 2006, 02:24 AM
I'm also in the camp that doesn't see much value in SELinux for home use. Especially for beginners, it's best to just disable SELinux and try to get a feeling for how things work.

ryptyde
7th September 2006, 02:59 AM
You can add a graphical user interface to the System menu to change the security and firewall settings:


system-config-securitylevel is a graphical user interface for
setting basic firewall rules.

It will be available by going to System>Administration>Security Level and Firewall.
Check to see if it is already installed if not open a terminal and as root:


# yum install system-config-securitylevel

Phil

Wayne
7th September 2006, 03:12 AM
If it's already installed, it's easy to turn off via editing this file:
/etc/selinux/config
to set SELINUX to disabled:

SELINUX=disabled

There might be some GUI control that edits that file
the same way but that's what I did.

Mark

I have SELinux disabled also, I can't bear futzing around getting apps to play nicely with it and don't see much use for it on a home PC either.

Is it possible to install FC5 without SELinux or is it possible to remove it without it wanting to take half the system with it?

Wayne

Iron_Mike
7th September 2006, 03:41 AM
You know I mostly agree with the majority so far, but there is a usefulness for SElinux and yes it does cause some hiccups but personally I've had very few errors leaving it "enforcing". I'm currently running FC6T2 so don't hold me to this as the gospel, just my .02 fr worth

marko
7th September 2006, 03:42 AM
I'd leave it alone, with the disabled flag set, it's off and shouldn't bother you.

I tried to yum remove it once and got lots of complaining from yum about
"such and such depends on selinux-policy..." blah blah so I left it alone.
I have a feeling it's deeply embedded by RedHat into the OS.

Mark

Wayne
7th September 2006, 03:48 AM
I'd leave it alone, with the disabled flag set, it's off and shouldn't bother you.

I tried to yum remove it once and got lots of complaining from yum about
"such and such depends on selinux-policy..." blah blah so I left it alone.
I have a feeling it's deeply embedded by RedHat into the OS.

Mark

That's a pain. I hate having things on my PC I don't use :( It'd be like filling my desk drawers up with trash :D

Wayne