PDA

View Full Version : Fedora 1-3-5



BlackBolt
6th September 2006, 04:05 PM
Heya this is my first post (I know nobody cares :p)
OK I have a problem (and yes I searched with the key terms) with FC5. The refresh rate says 85 but it seems more like 60 or 72 to me... any solution?
Second problem would be the fact that all windows and font seem so big compared to the previous versions... I used 1 and 3 a bit when they first appeared and they were easier to handle, but have mercy cause I'm not a Linux pr0.. but I'm willing to learn now that I got bored of games and such and deleted XP :)
Anyway another "issue" would be the Add/Remove Software prog which isn't responding (not under root) when I'm trying to install stuff and it checks for dependencies... oh and another thing.. it all seems so laggy in this OS; idk what's the problem. I have FX, Ath XP and 768 RAM so it oughta be more than OK. Do I need some drivers or such?

p.s. how can I install the rest of the packages from the DVD distro? At boot I don't have the same options compared with teh first install.. so I wanna choose what to install.

edit 2: OMG I just noticed that I have 731 megs USED and 41 available atm... WTF?
k It was some gj program that used 600 megs O.o I killed it, but still the scroll bars and windows are still LAGGY when I move them around

oh my last question before I die is how can I find out how my hard is partitioned and with what letters?
I have a 40GB HDD, 15GB + like 100mb (not swap but I guess it's too late to make it a swap one now?) + the rest 22GB~ (which is NTFS...and I need the space but of course idk how to mount it if I can't see it and looks like ntfs-3g is giving me some fdup errors)

dishawjp
6th September 2006, 05:51 PM
Hi Blackbolt, and welcome to the forum.


The refresh rate says 85 but it seems more like 60 or 72 to me... any solution?
Second problem would be the fact that all windows and font seem so big compared to the previous versions...

Run system-config-display from a terminal and as root. This will allow you to make certain that your monitor and video card were properly detected and configured. You can also set the resolution from that utility. The slow refresh rates and low resolution are probably due to the wrong hardware being selected and xorg defaulting to something "safe."


Add/Remove Software prog which isn't responding (not under root) when I'm trying to install stuff

That program, Pirut is its name, is only used for installing software from your initial installation media. Use yum to update your system (yum update) then install Yumex (yum install yumex) to install software if you want a graphical software installer.


OMG I just noticed that I have 731 megs USED and 41 available atm... WTF

Linux allocates RAM differently from how Windows does. It will make space by dumping recently used stuff from RAM when RAM is needed. Don't sweat this; nothing is wrong.


oh my last question before I die is how can I find out how my hard is partitioned and with what letters?

As root give the command "fdisk -l" to list your partitions.

HTH,

Jim Dishaw

BlackBolt
7th September 2006, 12:41 AM
OK thanks a lot.
Now maybe someone can answer the rest of my issues O.o

btw this is my xorg.conf file, and yes I chose the hardware well (in fact the default choices from anaconda were correct)


# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, a font server independent of the X server is
# used to render fonts.
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"

### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Samsung SyncMaster 753DF(X)/703DF(X)/783DF(X)/CD173A(T)"
DisplaySize 320 240
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 30.0 - 71.0
VertRefresh 50.0 - 160.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "vesa"
VendorName "Videocard vendor"
BoardName "nVidia Corporation NV34 [GeForce FX 5200]"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

edit: I just noticed it says horiz 30-71.. :eek:

dishawjp
7th September 2006, 01:22 PM
Section "Device"
Identifier "Videocard0"
Driver "vesa"
VendorName "Videocard vendor"
BoardName "nVidia Corporation NV34 [GeForce FX 5200]"
EndSection

Here is your problem. You have an nVidia video card, but for some reason only the vesa driver is loading. As I said in my first post, xorg defaulted to something "safe." You have a few options. One (and this could get scary if it goes wrong) is to manually change "vesa" to "nv" which would (err... should) load the open source nVidia driver. If that loads, performance will improve. I just don't understand why, after detecting the card as nVidia, it only loaded the vesa driver.

But first I would try running "system-config-display" again to see if you can get the "nv" module to load and get your xorg.conf automatically rewritten. That is the safest way for you and the least likely to damage your system. Unfortunately it's also the least likely to work since it failed the first time.

A second option would be to install the binary proprietary driver from nVidia. The easiest way to do this is to follow these instructions:

http://stanton-finley.net/fedora_core_5_installation_notes.html#nVidia

If you choose the first option, you might also want to try "lsmod | grep nv" to see if the open source nv module is loaded on your kernel (so that xorg can use it) and a "modprobe nv" to see if you can get it to load it if it isn't. Check with lsmod to see if it loaded and then edit your xorg.conf, reboot to see if that works. The danger is that you *may* get things so hosed that X won't start at all, so be careful and back up your configs so that you can change things back if it goes badly.

Good luck,

Jim