PDA

View Full Version : Failed to start the X server (your graphical interface). It is likely that it is not



techcon
6th September 2006, 03:47 PM
I am a new user with Linux and with your forum and need an immediate help as one of my production boxes went down all of the sudden

I tried to reboot the server a screen comes on saying "Failed to start the X server (your graphical interface). It is likly that it is not set up correctly. Would you like to view the X server output to diagnose the problem?"(Yes/No)

After clicking yes there is another screen saying

Fatal: Module mack64 not found
(drm) failed to load kernel modile "mach64"
(EE) ATI(0) DRIScreenInit Failed
Could not init font path element unix/:7100, removing from list!

Fatal server error could not open default font 'fixed'

in the end there is an exit button and when you click on it you get a blank screen and after that you can not do any thing..

dishawjp
6th September 2006, 05:58 PM
Have you recently done a kernel upgrade? It looks like you're running an ATI video card and xorg is unable to find/load the module and your Xserver is dying as a result. If this is th ecase, at the grub prompt, try to select an earlier kernel and see if you can boot. Alternatively, boot to runlevel 3 (at the grub prompt, enter "a" (without the quotes) and then "3" (also no quotes) which will boot you to a console (no X server.) You should then be able to work with your system.

HTH,

Jim Dishaw

techcon
6th September 2006, 06:58 PM
Thanks Jim, I did not upgraded my kernel at all....

I was googleing and found some recommendations to fix this

sudo apt-get update
sudo apt-get upgrade
/etc/init.d/gdm restart

This will replace your X server and restart GDM so you can login.

WOuld you recommend this as well? I am going to my colo tonight to get this done

dishawjp
6th September 2006, 07:24 PM
I hope that works for you. Apt-get has been deprecated in FC5 and is not installed by default. Of course, you didn't state which version of Linux you're running, so I was figuring you were using FC5 which is the current version.

Also, you had stated that you were left with a blank screen and couldn't do anything. I was assuming a kernel panic situation where you would not be able to enter any commands.

Good luck, and let me know how you make out.

Jim

techcon
6th September 2006, 07:48 PM
YEs I am running FC5 so this might not be an option... I havent tried rebooting the machine in text mode so I am presuming that will work and it would allow me run some commands...

Any recomendations on what if i dont get that system booted even in the comand mode?

dishawjp
6th September 2006, 08:06 PM
If the machine will boot in text mode (runlevel 3) issue this command to update all your installed programs: "yum -y update" without the quotes and as root. If you do not wish to update the kernel, the command should be changed to "yum -y update --exclude=kernel" If you have installed third party drivers for your video card (unlikely on a server, which often does not even have Xwindows installed) you will lose them in a kernel upgrade. To see if they are installed, the command "lsmod | grep fglrx" will tell you if they are for an ATI card. To remove them, the command would be "rmmod fglrx" The drivers are actually a kernel module and I suspect that is causing your problems from the error messages in your first post. But also upgrading your kernel and running system-config-display should get you out of trouble.

You will have to bring your Internet interface up first in the event it does not come up on boot. If the server has a single ethernet card, this command would be "/sbin/ifup eth0" If it has more than one ethernet card, substitute the number of the card which is the Internet interface for the ) in eth0.

Once you've updated your software, the "system-config-display" command will rewrite your xorg.conf file.

If it won't boot at all, then you have to either boot from a rescue disk or from an older kernel if you have one. I described that process in my first response. From the grub prompt, select a kernel, type "a" to append an instruction and then type "3" to enter runlevel 3 or text mode.

One thing to consider since this is a server would be to edit your /etc/inittab file to change the default runlevel from "5" to "3" so that a failure of X doesn't bring your server down or prevent you from working with it. Of course I'm so old fashioned I still boot to 3 on my desktops and use the "startx" command if I want/need a GUI.

HTH,

Jim

techcon
7th September 2006, 07:09 PM
Jim, Thanks a lot of taking time and helping me in this trouble..


I was able to booot the machine with the runlevel3 and every thing worked fine.. I did the yum update without the kernel one and i noticed that it had about 166 various updates for my OS.. after that I ran system-config-display and it did something but did not fixed the issues

I then changed the inittab file and selected the runlevel3 as my default boot option.. every thing works fine now except the xserver but you know i just reliased that I dont need xserver with all these 100's of programs installed on it. I am thinking to do some clean-up by uninstallling all these programs which we dont need but I am not sure what is the easiest way to do that... I am thinking that this will increase the performance of the system

Thanks again for your help and let me know if you have any tip on uninstalling the xserver and the GUI from my box

dishawjp
8th September 2006, 12:58 PM
Hi Techcon,

Glad that your server is up and running again. I wish that I could give you better info on safely getting rid of Xwindows and your desktop environments, but given all the interdependencies, selecting and removing components without accidentally hosing something you may need... I don't feel comfortable advising you. You stated that this is a production server. If it were a non-critical machine and I knew exactly what you were counting on and what you didn't care about, my answer might be a bit different. But given the circumstances, my recommendation would be to leave well enough alone.

The next time you set up and configure a Linux server give serious consideration to not installing X windows or any Desktop Environment. It's not that they will slow you down particularly, and the disk space isn't usually a consideration, but every piece of unnecessary software installed is just another bunch of vulnerabilities leaving the potential for a successful attack.

For now, just keep all your unused ports locked down (set iptables to "drop" rather than "deny"), set selinux to enforcing, make sure that you have tripwire installed, consider installing snort and ethereal (or wireshark) to monitor traffic and do some sort of an integrity check (the rpm -Va command on directories like /bin, /sbin, and /etc works great and required no new software) and all the other normal sysadmin tasks should keep you secure.

Hell, this is Linux, do half of the above and you'll probably be OK. But if you care about your job, do all of the above and back up all your data regularly.

Have fun!

Jim