PDA

View Full Version : Can't get bell to sound on ctl-g



buddy1138
6th September 2006, 03:36 PM
I am using Fedora Core 4 and cannot get the bell to sound. I know the internal speaker works as it beeps on boot. I have opened a terminal and typed ctl-g and I have used printf("%s\a\n","Bell") with no results. I have been all over the settings in desktop - preferences - sound and the profile settings in a terminal window. I am at my wits end. Any help would be appreciated. Buddy

homey
6th September 2006, 05:12 PM
It used to be controlled in /etc/inputrc . Now, you load the pcspkr module.
For example:


modprobe pcskr
You may want to do something like this to keep it through reboots.
echo "pcspkr" >> /etc/modules

If using /etc/modules doesn't work, you may want to use something like this...


(echo '#!/bin/sh'; echo 'modprobe pcspkr') \
> /etc/sysconfig/modules/pcspkr.modules
chmod +x /etc/sysconfig/modules/pcspkr.modules