PDA

View Full Version : Upper/lower case filenames on CD-ROM



Seehund
5th September 2006, 05:28 PM
Hi,

I have a commercial CD-ROM meant to be read with Windows and MacOS, and I'm trying to browse the HTML documentation on the CD-ROM in Fedora Core 5. I can't do this directly from the CD-ROM however, because in Fedora all filenames on the CD-ROM are displayed only in lower case while the HTML documents and the browser obviously are case-sensitive. I have to copy the files to my computer and either rename them all to upper case or edit the HTML documents.

Now I wonder if there's anything I can do to make Fedora read the CD-ROM properly to begin with. For example, where do I change file system mount options for the CD-ROM? There's no entry in /etc/fstab.

This is the relevant output from "mount":
/dev/hdc on /media/CanonDC260W type iso9660 (ro,noexec,nosuid,nodev,uid=500)

JoeyJoJoe
5th September 2006, 06:57 PM
hmmm, as far as I know all linux distros are case sensitive, and I think on my cds I've seen it display the case of files... what might be the problem could be if there are spaces within the file names, I know linux doesn't like them in the terminal, maybe it is an issue like that?

Seehund
6th September 2006, 05:17 AM
hmmm, as far as I know all linux distros are case sensitive, and I think on my cds I've seen it display the case of files... what might be the problem could be if there are spaces within the file names, I know linux doesn't like them in the terminal, maybe it is an issue like that?
Yes, I'm aware of that unices generally are case sensitive... ;)

No spaces present. For example a folder on this CD-ROM listed as "IMG" in Windows becomes "img" in FC. It also affects filenames that are longer than the 8.3 format (an issue to be considered when mounting FAT media), e.g. "README_INSTALL_ENGLISH.HTML" is listed as "readme_install_english.html". This goes for both the terminal and stuff like Nautilus.

I suspect I might need to play with something like the "map" option for the iso9660 filesystem. I just don't know where I'm supposed to do this, now that CD-ROMs and other automounted devices in /media aren't included in /etc/fstab.

JoeyJoJoe
6th September 2006, 02:03 PM
so I dug out an old CD to see how mine workes (I stopped using them ages ago :S)

anywho, the output from mount for this CD, which works fine is;
/dev/hdc on /media/Apr 27 2006 type iso9660 (ro,noexec,nosuid,nodev,uid=500)
which seems the same as yours there...

On the subject of capitals, it kept that on the CD, I'm not sure as to why it would lose them.
Would it be feasable for you to copy the CD to your HD and then burn it in FC back to a new CD? I would think that should solve the problem - although might waste a CD...