PDA

View Full Version : can not log into .xsession_errors



marisdembovskis
5th September 2006, 04:44 PM
i have everything ok but then electricity was lost for a second and my pc turned off. I started it and it says: (appears after I type login and password)
on dark blue screen

"your session only lasted less than 10 seconds.
If you have no logged out yourself, this could mean
that there is some installation problem or that you may
be out of disk space. Try logging in with one of the
failsave sessions to see if you can fix this problem."

~/.xsession_errors fault

/etc/gdm/PreSession/Default..............
/etc/gdm/PreSession/Default......runnning...
/etc/X11/xinit/Xclients line 34
/etc/X11/xinit/Xclients line 34

_----------------__------

//after I saw this i loged in via terminal
typed command startx and then system said that there is some lock /tmp/.X0
I delete that file but anyway that error jumped out after typing user and password.

any ideas
how to fix
this problem.
??????????????

tashirosgt
6th September 2006, 02:59 PM
Can you log-in from a console ( CTRL-ALT-F2)? If so, create a new user and see if he can login normally to a graphical desktop. This would indicate that some file such as .Xauthority or some .gnome/* file is corrupt for your old user.

marisdembovskis
7th September 2006, 07:30 AM
I can create new user.
But the most interesing is that I can not log with normal user (who was working) and neither with root and other users. Ok create a new user is another option. :)
thanks!

I guess there is something with X, because it was running and not stopped.
And it looks, that it somehow things that X is somehow saying that it is running.

tashirosgt
7th September 2006, 05:47 PM
Is the new user that you created able to login to a graphical desktop?

hazwan07
13th October 2006, 09:52 PM
hello.i had the same problem.10 seconds login than back.but the difference is i can login with root.and creating new user won solve the problem.i am new to fedora and don know how to diagnose the problem.can someone point out for me??

tashirosgt
14th October 2006, 05:09 AM
If you use gnome, look in the logs and see if you see the problem reported. ( /var/log/gdm/:0.log or :1.log ) . Most of the times I have seen threads on this topic the problem is solved by reinstalling things. I think the problem is often caused by a bad configuration file in the users configuration directories (.gconf, .gconfd. .gnome, .gnome2) or a bad .Xauthority file. You could compare what your user has in these files to what root has. Perhaps someone will explain the .Xauthority file to us. I think it is related to identifying the user to the X server.

hazwan07
14th October 2006, 08:54 AM
em.i on bandwidth.i live in russia for the time being so it is hard for me to reinstall things cause internet is expensive here.other solutions??some kind of scripts or magic words in any of the configuration files??

this is from my log


X Window System Version 7.0.0
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 7.0
Build Operating System:Linux 2.6.9-22.18.bz155725.ELsmp i686Red Hat, Inc.
Current Operating System: Linux localhost 2.6.17-1.2187_FC5 #1 Mon Sep 11 01:17:06 EDT 2006 i686
Build Date: 06 March 2006
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Oct 14 11:36:53 2006
(==) Using config file: "/etc/X11/xorg.conf"
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning: Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
> Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server

tashirosgt
14th October 2006, 04:05 PM
I scanned the recent forum messages on this topic. Let's try the last suggestion in the thread:
http://fedoraforum.org/forum/showthread.php?t=114044&highlight=less+than+10+seconds

Do you find a message indicating the same problem with executing /etc/X11/init/Xsession and does this file exist on your machine?

ls -l /etc/X11/xinit/Xsession

hazwan07
14th October 2006, 05:37 PM
ok.it gave me this when executed

[root@localhost /]# ls -l /etc/X11/xinit/Xsession
-rwxr-xr-x 1 root root 3395 Feb 16 2006 /etc/X11/xinit/Xsession
[root@localhost /]#

is it something to do with permission??

FarmBoy
14th October 2006, 06:32 PM
Whenever I try to log in as a user, I get a message telling me that my home directory is /home/username "but the directory does not seem to exist". Please tell me some one else has experience theis and knows how to fix it. I can only login as root. Please help.

tashirosgt
15th October 2006, 04:02 AM
I haven't had this problem before. See if the directory exists. Say the user's name is Wally. Open a terminal and try, as root,
ls -l /home/Wally
If it doesn't exist then you although you can create it and set it user and group to Wally, you might have more problems because /home/Wally won't have files like .Xauthority, .gnome etc. So my advice would be to create another user.