View Full Version : install rpm without internet access

5th September 2006, 08:17 AM

What do I have to do, if I want to install an rpm while I do not have internet access for the next two weeks?
I found an on the downloaded Fedora dvd, but the package installer keeps complaining about a missing internet access? Is a disc containg the software not enough? Shouldn't the dependancies also be avaiable on the disc too? It was on the disc while I installed Fedora, wasn't it?



5th September 2006, 08:44 AM
Well, you can copy the rpm from the disc that you have and rpm -ivh or if you really need to you can create a local yum repo: http://www.city-fan.org/tips/YumRepoFromImages


5th September 2006, 08:54 AM
You can copy the files to an empty folder on the HD and install them with rpm -i packagename.rpm. If it complains about dependencies, you have to find them and copy them to the same folder and try again with rpm -i *.rpm. when you find all the dependencies and get the packages installed, you can delete the files and start over with the next one.
Edit: Sorry Seve You beat me to it again. I had it typed for a few minutes but forgot to send it:D

5th September 2006, 11:58 AM
Aha, that's the way it can be done. Well, I'll give it try this evening.
Thanks for your help (both of you ;) )

5th September 2006, 02:05 PM
You can use "yum localinstall rpmfilename" to install
a local rpm file:

yum localinstall seamonkey-1.0.4-0.i386.rpm

for example

6th September 2006, 10:06 AM
Couldn't make it. :( It kept complaining about the repository jpackage-general, that it could not find. No matter what I tried.

6th September 2006, 10:23 AM
Was that with rpm -i *.rpm or with yum localinstall? I don't think I have used rpm since I upgraded to FC5, but it never tried connecting to repos with FC3.
With yum localinstall, it will still try to connect to repos if it needs dependencies

6th September 2006, 10:33 AM
It was with yum localinstall!
I will print this page and try it with rpm -i when I'm at home. It does complain about jpackage-general. Is there a rpm on the FC5 dvd too, that I can install via rpm?

6th September 2006, 10:57 AM
rpm might complain about dependencies, but they should be on the CDs too so just find them and copy them to the same dir you put the other package in.

6th September 2006, 11:37 AM
You should use
rpm -U

for everything, but the kernel and kernel-modules. -U looks, if there is the packages allready avalaible and updates it, and if not installs it. -i just installs this version despite the fact there might be an older one.

6th September 2006, 11:47 AM
That could be useful too. Because when I searched for something like *blue* there where already things for bluetooth in the usr tree for example. So serveral things might already be installed.