PDA

View Full Version : amarok doesn't start after updating to 1.4.2-1.fc5



Deady
5th September 2006, 07:48 AM
I have updated amarok via yum to version 1.4.2-1.fc5.
when i try to start it:


[Deady@penkov ~]$ amarokapp
amarokapp: symbol lookup error: /usr/lib/libamarok.so.0: undefined symbol: _ZN9KLineEdit13focusOutEventEP11QFocusEvent
[Deady@penkov ~]$


how can I fix it?

LocutusOfBorg
5th September 2006, 07:57 AM
Try rebuilding the source rpm.

Deady
5th September 2006, 08:28 AM
# rpm -e amarok
# yum install amarok-1.4.1
# yum install amarok-extras-nonfree-1.4.1


solved my problem :)

rebuilding from source needs installing to many devel packages, and I'm so lazy

sueltraz
6th September 2006, 07:52 AM
Just out of curiosity, does anyone know why the Amarok developers requested that Amarok not be build on 64 bit systems? The .spec file has those architectures excluded and a comment saying that the Amarok devs requested this.

tangotiger
6th September 2006, 08:29 AM
I don't know if this is the reason, but since gstreamer was dropped from amarok at 1.4.1, we had the strange situation of amarok not having an engine for x86_64 fedora. I'm not too sure about the rest of the story though.

sueltraz
7th September 2006, 04:51 AM
Okay...I read the comments in the spec file more closely and you're right. It turns out that the amarok dev requested the exclude because of the strange situation.

*Mental Note* RTFM next time.