PDA

View Full Version : trying to install DivX Codec to play .avi or .mpg



crmpicco
4th September 2006, 03:18 PM
I was wondering if someone could help me.

I am a nooB to FC5 and I am trying to install DivX codecs and a media player to allow me to play .avi and .mpg files. I have tried numerous sources and looked for guides to do it, but can't seem to get it to work.

Can it be done in a GUI for start to finish? Like the GUI that Windows gives you when you run through and installation?

Has anyone got accurate links for downloads? and can the Totem media player play .avi's with the codecs installed?

Help appreciated.

Picco

bigboss2200
4th September 2006, 03:30 PM
try this link for VLC... i hope it works :D

http://www.videolan.org/vlc/download-fedora.html

crmpicco
4th September 2006, 03:37 PM
hi bigboss2000, thanks for your link. i had actually came across that before, believe it or not.

can you tell me if VLC Player comes with the appropriate codecs??

Also, how do i get to this stage "rpm --import gpg_pubkey_jean-paul.saman.asc" ??

I can get to the terminal prompt, by going to Applications>Terminal.

What do i do after that?

Thanks mate.

Picco

crmpicco
4th September 2006, 03:39 PM
do i copy this (below) into a text file then run the command? Can i not just install it using a GUI? does FC5 not have a GUI like WinXP???

-----BEGIN PGP PUBLIC KEY BLOCK-----
Version: GnuPG v1.4.4 (GNU/Linux)

mQGiBES/Ug0RBADAmAI3ZFGeEMHk8GcibKRhO9lmwHUdi7EOn3+se7OISD d1cG4k
MaDOuNKBUnGiVaIzrRgGgev38XfSrfw8XYCgvfIEMHhwh+zfXe k8szvh/biomLVr
hNRcYVglZjS8ujS0toK9bSqtclny82vVp5aiMNVEtwWlC7yFv2 f677d9rwCgsl1p
T88Pu0LTFZTnlAodhkS8ew0D/j0lpwVA0boqVDz1xmvMgd+uVeiEb+3WxDwTQmOP
KoacDdUHUDAKsJego5ecXMJ+p5AnryBQNK080tdtTCHItSLy0V kmatJCkz1oOmMf
5+Lu9W03D4WmFyGt8YRcy0PUXE5xjMJRLvzdu+PzyPlUPK+7dN p1nQcPIW76FjZy
ISQxBACFnFq5/qssV0b31+glG1fYnfYGcEKxyx/+w8WJVZz7iUe1TatiN3n9477T
HT/VbCWTvlEiyyO1TAlC/9KwE8j8MPacjU5kss6ycYglBXIkBkekG9+Lil4tVrhO
S8aiSaYrIIH3Wl0BhzTQMAkMYrTxcjVSe3nnoaw9aUXgdF3XRr RJSmVhbi1QYXVs
IFNhbWFuIChNdWx0aW1lZGlhIE5ldHdvcmtpbmcgRW1iZWRkZW QpIDxqZWFuLXBh
dWwuc2FtYW5AbTJ4Lm5sPohgBBMRAgAgBQJEv1INAhsDBgsJCA cDAgQVAggDBBYC
AwECHgECF4AACgkQa1fBOulIyvBgwwCfUSDWn5dISmxkslIy5s iHqGhepRMAn10E
mrS2W0bak1l7Irni8gqfmsGQuQINBES/UhMQCAC1djDBrwWyl90gVgxsn9pXWtXD
heA4JNP2Dq2/haOOy+a6WNUllCg4MMw9IZvfOTby8D2i7hsJopu5Yq8/V699dqW7
EnpUaWbluy+28k0wV19FNQBmbadxPLP0+9XrjSCFAD4QTcEpm/j9DfSFbCv5WsiL
0bjc5CF1f+yfVtt6uJN4WOYb4Ih0y/I7B3aysNdHilfn4trQeylmeZOtoJU8tfSz
5sM55C3wuNDO2YAwZm7zhFgUJDnnNYrA2D5z9/b3bOZMI4YY8AUUTnVPweEUZj9Z
M4exMGlylQY2xUduO1SeZrbq2D5oe9gTzybHb3CDwTFBR0vEmd fm7OvcI9CPAAMF
CACnuhHnwbaiA5OyEhTtSCEXHUv8oXexyJYPvofKKhQtYN9cKw j6W3D8ldkf+TY3
VFn8bv78aIaGTwjOKd3t/o2MkUQ3VjtBm8dMrK04DfBo+aSkH6zNEPvQgEw27vvs
XMmVjpeH9M083dkCK7VTsD1DSY41gR43p60FsE47DfaeLNJiPW 0O07+R34Hl9Q/W
+vjMfyYFjoTk/17j4ThuTKQCv4y2mvMJuAgujDonFffCxvowapFeRBnboxEWSAZ l
ZWkbGw5bxIw7wsiMoMLKwn1iyYyDht0KiCOEXvVucYL5gAyFLJ GBanh0eYwGI0DT
UNYn74Rmp5ZH/1vm2BiHNJ3giEkEGBECAAkFAkS/UhMCGwwACgkQa1fBOulIyvBQ
0gCfT8PpeZzqxakUY1Qa+6EuGXS8WfcAoJdjxu0D3LByC7jq4z 91LUP9bdQ0
=xxN4
-----END PGP PUBLIC KEY BLOCK-----

Help VERY MUCH appreciated.

Picco

bigboss2200
4th September 2006, 03:45 PM
well, i dont think i can be *that* help for you, because i never used rpm to install from internet before because i dont have internet connected to my Fedora :)

but anyway.. i'll try to explain :D

1- download the PublicKey "as mentiond in the site".. and put it in ur desktop
2- open ur terminal
3- type " su " (without comments) --> this step is important, because u cant install if u arent root.. and this step will give u the root permision to install
4- type in ur root pass
5- go to ur desktop (lets say my userID is Faris.. so i'll be typing the following: cd /home/Faris/Desktop "
6- type in the following command: "rpm --import gpg_pubkey_jean-paul.saman.asc"
.
.
.
.
.
continue now with the tutorial ;)


if u still have any other questions please feel free to ask ;)

crmpicco
4th September 2006, 03:51 PM
sure, when i click on 'Download the publickey here' it just shows the public key in the browser, do i copy/paste it into notepad, and save it as a '.asc' file?

the instructions were GREAT, i will try them as soon as I get this bit sorted out...cheers

bigboss2200
4th September 2006, 03:58 PM
to get the long story short, right click on that link -> save as..

and thats it..!

crmpicco
4th September 2006, 04:10 PM
cheers bigboss2000!

i ran the commands, follwed your instructions and I was left with a blinking cursor at the command prompt, no errors. It just read:

[root@localhost Desktop]#

I dont have a internet connection on my machine with FC5, how can i continue with the tutorial as it stands? Is there a way I can now just download an installer and run through it like WinXP???

Picco

urzasrage
4th September 2006, 04:48 PM
Follow the instructions in the Fedora FAQ
1. Configure yum as instructed here (http://www.fedorafaq.org/#installsoftware)
2. In a terminal, type in yum install mplayer-gui

crmpicco
4th September 2006, 04:53 PM
hello urzasrage, thank you for your reply.

i have heard of 'yum' and look at 'yum extender' as well, got a bit lost however :-(.

my problem is that I am not connect to the WWW on my FC5 machine and ther instructions on fedorafaq.org say "Run these commands to remove your yum.conf file and replace it with a fresh one (Updated 1 May 2006):"

do i have yum installed from my bordeaux DVD??

Can i still install without a WWW connection?

Picco

Skinney
4th September 2006, 04:56 PM
why not just install Mplayer's essential/all codec pack? that way you can run pretty much every video file out there... you can find instructions on how to install them on Stanley Fintons site (http://stanton-finley.net/fedora_core_5_installation_notes.html#Codecs)

Note: VLC uses internal decoders instead of codecs, when using VLC codecs are therefore not required... I still recomend installing the codecs as described on Stanley Fintons site and using Mplayer/Xine as a mediaplayer though, simply becouse VLC does not support as many formats as those codecs do... (like .wmv)

crmpicco
7th September 2006, 11:48 AM
hello skinney, i have download the codecs and installed them likes this:

Multimedia Codecs:

* To get the most out of Xine and other media players such as MPlayer you will need to install additional codecs. In order to do this open Firefox, go to http://www4.mplayerhq.hu/MPlayer/releases/codecs/ and download (save to disk) all-20060611.tar.bz2. This should save the file to your home folder. If it saves the file to your desktop instead go to your desktop and drag the file into your "Home" folder. (Left mouse click on the file and drag it on top of your "Home" folder while holding the left mouse button down. Then release the mouse button.)

* Open the terminal. Type:

su

Hit enter. Type your root password. Hit enter.

* Type:

mkdir /usr/local/lib/codecs/

Hit enter.

* Type:

mkdir /usr/lib/win32

Hit enter.

* Type:

tar xvfj *.tar.bz2

Hit enter.

* Type:

rm *.tar.bz2

Hit enter. Type "y" and hit enter.

* Type:

cp ./all-20060611/* /usr/local/lib/codecs/

Hit enter.

* Type:

chmod 755 /usr/local/lib/codecs/*

Hit enter.

* Type:

cp /usr/local/lib/codecs/* /usr/lib/win32/

Hit enter.

* Type:

rm -rf ./all-20060611

Hit enter. Close the terminal. The additional codecs are now installed.

However, I am still getting this error message:

Totem could not play 'file:///home/crmpicco/test.avi'
You do not have a decoder installed to handle this file.

Notes: Totem Movie Player 1.3.92
Movie player using GStreamer 0.10.3

crmpicco
7th September 2006, 12:29 PM
do i need to install Xine? if so, does anyone have any instructions or a line on how to do it? As i say, i am a nooB and dont have an WWW connection to my FC5 machine sadly.

i have searched google to find a way to install Xine from file, but all instructions require a connection to the WWW on the machine it is being installed onto :-(((

Any help much much MUCH appreciated.

Cheers.

Skinney
8th September 2006, 01:30 PM
ahh, that's becouse Totem uses the Gstreamer engine. you could install some codecs for gstreamer like gstreamer-plugin-bad and gstreamer-plugin-ugly(or something like that, don't know the exact name for these files...) or you could use Mplayer or Xine... Mplayer is my best choice but you're free to make your own opinion.... You should find Mplayer by searching google yet the easiest to do is install it via Yum(it's installed with your Bourdeux DVD) or YumEx...

In terminal simply type:
su <enter>
<root password then enter>
yum install mplayer/xine

should be that simple...

crmpicco
9th September 2006, 11:40 PM
hi skinney, thanks for your reply. i have tried 'yum install xine' before but I got that baseurl error...... :-(

its because i dont have a WWW (internet) connection on my FC5 machine.

I haven't got a good response really, due to the fact I have no WWW access on my FC5 machine. I would think this is a quite common thing, but seemingly there doesnt seem to be documentation out there (that I can understand) that will guide me through installing xine/mplayer from file???

I posted up onto a Google Groups for Linux and someone replied to this problem by saying "do you know what Fedora is?? its a test OS for Red Hat!!! if you want out-of-the-box linux try PCLinuxOS or Ubuntu".

actually, i was sent a Ubuntu CD-ROM through the post, is that the Linux Distro is should be looking for???

Skinney
10th September 2006, 10:17 AM
Ubuntu wouldn't do you any good either without internett access, Ubuntu actually gives you less packages from a cd install than Fedora does(after all, its only a LiveCD)... why is it that you don't have internett access on your linux?

anyway, download mplayer-1.0-0.46.pre8.lvn5.i386.rpm and mplayer-gui-1.0-0.46.pre8.lvn5.i386.rpm from Livna (http://rpm.livna.org/fedora/5/i386/)...

Install these files with:
yum localinstall mplayer-1.0-0.46.pre8.lvn5.i386.rpm mplayer-gui-1.0-0.46.pre8.lvn5.i386.rpm

and that should do it...

crmpicco
11th September 2006, 04:00 PM
hi skinney, thanks very much for the reply post.....

i tried your method you mentioned above, but i get this error:

Error: Cannot find a valid base url for repo: core

Have you got any idea what this is and how to get around it??

crmpicco
11th September 2006, 04:03 PM
oh yeah, you asked why i didnt have WWW access on my FC5 box....its because it is in another room, and my WWW connection is downstairs. unfortunatley I cant have WWW access upstairs, but i just thought that I could install things via disks etc.....

crmpicco
11th September 2006, 04:04 PM
would i be better installing VMware on WinXP and installing FC5 that way and having a play with it? its not my preferred option, as I wanted to abandon Win.......:-(

Skinney
11th September 2006, 04:29 PM
Vmware would be a good option as you'd have WWW access on your winXP box(right) which would be emulated through Vmware, giving you WWW access on Fedora core, making everything easier ;) of course, speed wouldn't be as if running the real deal but what the heck...

The error means that it cant connect to the base repo, which is understandable as you can't connect to the internet... the problem is that when doing yum localinstall it shouldnt look on the internett... i think... try using "rpm -ivh mplayer-1.0-0.46.pre8.lvn5.i386.rpm mplayer-gui-1.0-0.46.pre8.lvn5.i386.rpm" (without the " ") and see what that gives you....

crmpicco
14th September 2006, 09:51 AM
hi skinney, thanks for your reply.

i'm just going to try your command you gave me above and i'll post back up my findings.......

(rpm -ivh mplayer-1.0-0.46.pre8.lvn5.i386.rpm mplayer-gui-1.0-0.46.pre8.lvn5.i386.rpm)

cheers.

Picco

crmpicco
14th September 2006, 10:45 AM
hi again skinney, i just tried the commands you gave me.......however, i get this set of errors:

WARNING: mplayer-1.0-0.46.pre8.lvn5.i386.rpm: HEADER V3 DSA signature: NOKEY key id a109b1ec

error: Failed dependencies:
libXvMC.so.1 is needed by mplayer-1.0-0.46.pre8.lvn5.i386.rpm
libXvMCW.so.1 is needed by mplayer-1.0-0.46.pre8.lvn5.i386.rpm
..... and so on ......
theres quite a few of these type of files, then a 'fonts' error message at the bottom.

do you have any experiance over these types of error messages? what should I try next??

oh, by the way, my football team - Glasgow Rangers, are in Norway playing a team called FK Molde tonight.......just thought i'd mention it

Skinney
14th September 2006, 03:36 PM
FK Molde is bad, Glasgow should kick ass ;)

ignore the warning its nothing dangerous... The dependencies error is the reason why having internet is a good thing in linux ;) For mplayer to function/install properly, its depending on other program and libraries(libXvMC.so.1 in your case), yum automaticly resolves this and downloads/installs the required dependencies... Since you don't have internett(consider VmWare for windows now(internett access)) on your linux box you'll have to write down each of these dependencies and download them or .rpm's containing them which depending on the software can become quite alot of packages....

An easier way would be to get gstreamer-plugin-ugly and gstreamer-plugin-bad (search for them on google, be sure to get FC5 .rpm's, shouldnt be difficult to find) and use Totem... You can't play everything using this, but you can play most things and should be ok for a demo/evaluation of Linux...

Anyway, Good Luck with Glasgow Rangers and your multimedia linux experience :D