PDA

View Full Version : KWalletManager won't start after latest FC5 updates



DaScoobsta
31st August 2006, 03:43 AM
I use KWalletManager all the time to manage my passwords but after running an update tonight it has stopped loading. I have tried running it from command line and from KDE menus, I get no errors, no output, nothing. :-(

The KWallet deamon appears to be working fine in the background because Konqueror and KMail can still access wallets. It's just the KWalletManager app that refuses to work any more.

Strange thing is, if I run it as root, it works fine. If I copy my user's wallet files to root's kwallet directory, they work fine too. Permissions for /usr/bin/kwalletmanager are 755 as I would expect.

I have tried deleting all kwallet configuration files and wallet files from my user's home but this makes no difference, KWalletManager just refuses to run as my normal user account. Can anyone help me out here? I don't want to have to run it as root just to get to my passwords all the time.

Amongst the updates I performed tonight via yum, were a lot of latest KDE packages. I fear it may be something to do with this... is there any easy way to roll back if so?

barko
3rd September 2006, 05:49 PM
Looks like a known bug..

http://bugs.kde.org/show_bug.cgi?id=129161

Can kill it and restart and it works:

http://www.redhat.com/archives/fedora-list/2006-August/msg02448.html

rclinux
5th September 2006, 11:21 AM
Thanks, barko! I got the same problem. Now it is right! :)

A really stupid bug. :mad: