PDA

View Full Version : Xawtv error



kayndy
28th August 2006, 04:54 AM
Hello everyone I am new to this forum. Thanks for any and all help provided.

I am using FC 5, with a Hauppage PVR-150. after several hours I finally got the ivtv module installed. That's another story. Anyway my current problem is that I have xawtv installed, and when I run it I get this error message

This is xawtv-3.95, running on Linux/i686 (2.6.17-1.2174_FC5)
WARNING: v4l-conf is compiled without DGA support.
/dev/video0 [v4l2]: no overlay support

I've looked for several hours on the internet and can't seem to find an answer most have to do with quickcams. I'm just trying to watch tv. I do have a .xawtv file in my home directory. I'm not sure If I need to edit that?

Please Help.. after i resolve this issue I would like to install MythTV but I thought it wise to get this fixed first.

This is my dmesg | grep ivtv output
ivtv: no version for "struct_module" found: kernel tainted.
ivtv: ==================== START INIT IVTV ====================
ivtv: version 0.7.0 (tagged release) loading
ivtv: Linux version: 2.6.17-1.2174_FC5 mod_unload 686 REGPARM 4KSTACKS gcc-4.1
ivtv: In case of problems please include the debug info between
ivtv: the START INIT IVTV and END INIT IVTV lines, along with
ivtv: any module options, when mailing the ivtv-users mailinglist.
ivtv0: Autodetected Hauppauge WinTV PVR-150 card (cx23416 based)
tuner 3-0061: chip found @ 0xc2 (ivtv i2c driver #0)
cx25840 3-0044: cx25841-23 found @ 0x88 (ivtv i2c driver #0)
wm8775 3-001b: chip found @ 0x36 (ivtv i2c driver #0)
ivtv0: loaded v4l-cx2341x-enc.fw firmware (262144 bytes)
ivtv0: Encoder revision: 0x02050032
ivtv0: Allocate DMA encoder MPEG stream: 128 x 32768 buffers (4096KB total)
ivtv0: Allocate DMA encoder YUV stream: 194 x 10800 buffers (2048KB total)
ivtv0: Allocate DMA encoder VBI stream: 120 x 17472 buffers (2048KB total)
ivtv0: Allocate DMA encoder PCM audio stream: 455 x 4608 buffers (2048KB total)
ivtv0: Initialized Hauppauge WinTV PVR-150, card #0
ivtv: ==================== END INIT IVTV ====================
ivtv0: All encoder MPEG stream buffers are full. Dropping data.
ivtv0: Cause: the application is not reading fast enough.
ivtv0: All encoder MPEG stream buffers are full. Dropping data.
ivtv0: Cause: the application is not reading fast enough.
ivtv0: All encoder MPEG stream buffers are full. Dropping data.
ivtv0: Cause: the application is not reading fast enough.

Thank you.

uth
8th September 2006, 04:35 PM
Hi, I don't think either of those are actual errors. The DGA one means it won't use DGA for fullscreen access. Not a big deal because there are several other ways to do the same thing, and everyone recommends not using DGA anymore anyway.

The second one means that your video driver does not support video overlay. Xawtv doesn't strictly need the overlay, but it's a real "nice to have" since it means that you can watch TV with much less CPU overhead.

If you run xawtv, in the GUI switch "overlay" to "grab display" and you should get a picture.