PDA

View Full Version : Total Newbie - No GUI



Lister
27th August 2006, 07:22 PM
Okay, probly my fault for not checking the hardware compatibility list, but I have just installed Bordeax on an old cobbled together machine to take a look.

Although I picked the graphical installer, there seemed to be some error which I've now forgotten (slapped wrists), and it defaulted back to the text installer all the way through. The install finished without further mishap.

When I now boot, I get a text shell. I am totally in the dark regarding Linux, but I know one of the GUI's is called GNOME, so I eventually found a load of GNOME files sat in usr/bin. I tried running GNOME-WS which did something, and the complained about a problem with X Window.

So I guess my graphic card is not supported. It is an old ASUS V7100PRO. There is also an ATI RAGE 128 built into the motherboard, so I enabled that instead and rebooted.

I was hoping the reboot would find the new card, but although it said "Checking for hardware changes", it didn't seem to do anything else abnormal, and gave me a text shell again. GNOME-WS does the same too.

So can anyone take pity on a newbie. I am a total loss now on what to do next. I have no idea where to look for graphic card drivers or settings from the shell. Can someone point me in the right direction?

Many thanks

Dan
27th August 2006, 08:31 PM
Hi Lister,

I can't answer all your questions. I'm a newbie myself. But I may be able to help some others by saving some time. Please give us the details about your system.

Memory Quantity? Type? Speed?
CPU Type? Speed?
MotherBoard? Graphics? (Oops! Got it.)
HDD? Size? Interface?

All that fun stuff will sure help to dig up some answers.

BTW, what happens if you type " startx " from the command prompt?

Dan

bob
27th August 2006, 08:42 PM
Try from command-line to sign in as root and type "system-config-display" and see if you can adjust settings to your particular machine that way. Once done, try 'startx' to boot into a desktop. If that fails, you can also try to adjust problem areas in /etc/X11/xorg.conf with 'vi' or 'nano'. If you use 'vi', you'll type: 'vi /etc/X11/xorg.conf' and then use your arrow keys to move through sections and make adjustments, maybe with the 'insert' key too. Before playing, of course it's best to rename and save a copy of your old xorg.conf just in case. When done, you can hit the 'esc' key to stop the editing, but then type ":wq" to save and exit, or if you've made a mistake, type ":q!" to dump it.

Lister
27th August 2006, 09:45 PM
Many thanks for the help guys.

After RTFM I tried an "init 5" which bumped me into gnome. I guess the "startx" command you told me does the same thing yes?

Looks like it's ok with the onboard ATI rage, but that the ASUS I had enabled when installing caused it to default to run level 3.

One quick question while I'm here (although I promise to RTFM some more). I have had gnome running for 3 hours now and I've done bugger all for the last hour, but my hard disk is still chuntering away in a seamingly regular cycle. Is this normal? Is there some daemon running that would cause this?

Thanks again.

marq
27th August 2006, 09:51 PM
The main reason you probably didn't have the great graphical installer is that I think FC 5 requires half a gig of ram before it will allow you to use anaconda (not sure exactly why but I'm sure there is a reason). Glad you found an answer because GNOME really is a nice desktop and quite configurable.

About the hard drive... what do you mean exactly that its chuntering? Before you answer give us an idea of what the specs on this PC are and that would probably help to understand and explain how the system may behave.

Lister
27th August 2006, 10:40 PM
About the hard drive... what do you mean exactly that its chuntering? Before you answer give us an idea of what the specs on this PC are and that would probably help to understand and explain how the system may behave.

Well it's a pretty ancient beasty. A P3 500 with 256MB of RAM. 8GB drive.

After my triumph of obtaining a desktop, I went downstairs for an hour. After 45 mins or so I could hear the disk start going nuts through the ceiling (the pc is sprawled octopus like across the floor at the mo and reverberates nicely :) ). After this had been going on for 10 mins I came up to see what was going on. After another maybe 20 mins of playing around in gnome, the disk was still chuntering away, even though I wasn't doing anything taxing at all - just looking at menus and the like.

By "chuntering" I mean that I can hear the drive heads seeking a fair amount. The disk isn't totally thrashing, but it sounds like a fair amount of activity. The PC isn't networked and is purely just sat on the gnome desktop without anything else open. The disk activity seems to have a sort of pattern, which repeats maybe every 5 seconds or so. :confused:

It wasn't doing this when I first booted gnome.

Seve
27th August 2006, 10:46 PM
Hello:
There is an excellent guide to services here: http://forums.fedoraforum.org/showthread.php?t=102853&highlight=services
you may want to go through and disable as much as possible to see if that helps?

Seve

Dan
27th August 2006, 10:49 PM
Hi Lister,

Great you've got it going! I think the disk activity is a disk indexing program called beagle. It's normal.


Dan

marq
27th August 2006, 11:47 PM
My disk is constantly writing from what GKRellm is telling me. Looks to be around 36kb of activity every 5 seconds or so. So yes, this very well could be beagle for you. Judging by the size of the drive I'm going to wager a guess that its either a 5400 rpm drive or slower which could obviously cause it to "chunter" a bit more than more modern drives. _SHOULDN'T_ be much to worry about, but yeah, check your services and disable things you know shouldn't be running. A good way to display services is either on the command line with ntsysv or through the gui by the System menu -> Administration -> Services (if you haven't tinkered your way that way yet). Glad your at least up and running and able to taste what gnome is :D. Good luck in your adventures!