PDA

View Full Version : yum groupinstall fails



apresley
25th August 2006, 05:11 PM
Hi all,

I recently installed FC5 on my Dell D820 laptop, and got all of my necessary hardware (wireless, etc...) working.

However, during the installation I only installed KDE. I'd like to be able to install GNOME, and I'm having some problems.

I have attempted to run:
yum groupinstall "GNOME Desktop Environment"

and also:
yum groupinstall "GNOME Desktop Environment" "Window Managers"

yum finds the files, resolves dependencies, and then prompts if it is ok to download the files. I answer "y", and it proceeds to download all of the files.

When they are downloaded, it claims to be "Running Transaction", and then ALL of the packages fail with an error. The error is:
"Error: unpacking of archive failed: cpio: lstat"

However, it finishes (all packages get that same error), and then claims to be "Complete!". No RPM files are downloaded into the /var/cache/yum (at least, if they are, they are immediately removed).

What's going on? How do I install GNOME?

Note: I have used yum to install other things (VLC, xine, mplayer, etc....), and today I installed acroread just fine. So, yum IS working and finding the right archives.

Thoughts?

apresley
2nd September 2006, 09:26 PM
I tried launching KDE's add/remove software, and selected "GNOME Desktop Environment", and after a few minutes it said it was complete. After a restart of the X Server though, I could see that the exact same problem was persisting.

I downloaded (manually) all of the necessary RPM's, and did an installation of the RPM's. The same error occurred. I then installed the RPM's using the -vv option, which showed that /usr/share/doc was not a directory. During my manual installation on the D820, I had tar'd up all of the /usr/share/doc to save some disk space. Apparently, the /usr/share/doc was recreated as a regular file (not a directory), and the RPM's could not install there.

After deleting the doc file, the installation worked perfectly.

--
Anthony