PDA

View Full Version : little boot problem



mlager
25th August 2006, 12:06 AM
Okay, this the thing. I've got multiple hdd in my computer. On the main drive, the 'c' in windows, I installed windows xp pro. On one of the other drives I installed Fendora Core 5. It all installs fine. But at the end of the Fendora installation it says you have to reboot. Not unlogical. But when I do reboot, it goes straight to Windows, no Grub or any other selection menu on which system I wanna boot. When I go to the bios and let it boot straight on the drive I installed Fedora on, it says 'Missing Operating System'. The big question is, how do I get it to boot on Fendora?
Clearly I'm missing something, probably something simple. But I'm, kinda new in all the linux stuff and I'm not seeing it. If someone can help me out here, well, please!

Mark

LLS
25th August 2006, 01:42 AM
If you have the time, a re-install and making sure you install grub on mbr of hda "first harddrive" should fix the problem the simplest way. If you want to try with linux rescue utility, do a search here for "install grub on mbr" and follow one of the many how to's my favorite is-http://forum.fedoraforum.org/forum/showthread.php?t=975&highlight=install+grub+mbr and that will get you fixed up.

mlager
25th August 2006, 02:27 PM
Thanks for your swift reply. I tried what you suggested ands reinstalled Linux. Unfortunately, it made no difference. I made sure it was installed in the mbr, and when that didn't work on the first partition of the hda. It still booted straight to windows without showing any bootloader.
I tried the link and followed the instructions. When I type in the command: grub> ' find /boot/grub/stage1', it replies with, 'Error 15: File not found'.
One thing changed though, when I let the computer boot on the drive I installed Fedora on, instead of coming up with 'Missing Operating System' it now comes up with Grub followed by a blinking cursor. Doesn't react to anything though.
Basically my little problem hasn't changed very much, still can't boot on Fedora.
Any (other) suggestions?

mlager
25th August 2006, 05:37 PM
The problem has been solved. Thanks for the help.

LLS
25th August 2006, 07:40 PM
What did you find out was missing?

mlager
26th August 2006, 11:13 AM
I think it was because of LVM section Fedora created when installing. Apperently it seemed to affect to location of the root/boot. Did a reinstall leaving the LVM out and installed Grub manually. It seemed to do the trick. Now it's time to tackle the next problem; Installing the video drivers and wireless network. The ATI drivers I downloaded from their website don't seem to do very much. When I go to the 'display' thingy in one of the menu's the system freezes. I installed Livna to get the drivers. But to actually get them you need to be connected to the internet. Which is kinda tricky since I can't find the drivers for my WiFi PCI card.

LLS
28th August 2006, 01:34 AM
start a new post now in networking after reading as many as you think may apply to your setup and post the contents of
/sbin/lspci and your general system specs motherboard, proc, etc and see if you can get some help. I have no wireless experence but there are many posts about madwifi and modporb and the likes.

mlager
28th August 2006, 11:43 AM
The problem here is the non-existence of linux drivers for the broadcom chip. Think I might install that program to run the windowsdrivers.

LLS
29th August 2006, 10:38 PM
This may be relevent to your wireless nic problem- http://www.fedoraforum.org/forum/showthread.php?t=29659

mlager
29th August 2006, 11:23 PM
The correct drivers should apparently be present in the update I did. But unfortunately the update caused a boot failure again. This time not kudzu or firstboot related. Already checked that.

http://forums.fedoraforum.org/showthread.php?t=122544

So far linux proves to be a continues chain of errors and boot failures in my case. I've been at it for a week now, and have yet to install a stable, good working enviroment.

LLS
30th August 2006, 01:24 AM
Some folks around here say that Centos is more stable less updating and better suited to desktop performance. I have no experience with it myself.