PDA

View Full Version : dual booting problem



disruptiveent
24th August 2006, 03:17 PM
i am new to linux. i used partition magic to create a linux (ext2) partition on my 80GB hd. The windows type is ntfs i installed linux on ext2. windows is still on the hard drive, however i can't get to it. i never get an option to boot windows. windows is: /dev/hda1, linux is: /dev/hda2, and the swap is: /dev/hda3. when i turn my computer on it boots straight to fedora.

funknor
24th August 2006, 03:27 PM
Edit the grub.conf in /boot/grub. It should have someting like this to add windows in the boot menu:

title Windows XP
rootnoverify (hd0,0)
chainloader +1
(hd0,0) should be for /dev/hda1

In case the you want the menu displayed directly, you can also add/uncomment the hiddenmenu option:

timeout=5
splashimage=(hd0,<your boot partition here>)/grub/splash.xpm.gz
hiddenmenu

disruptiveent
25th August 2006, 01:42 AM
i just tried to edit the grub.conf , and linux would not allow me to open it. the way i got to it was computer> file> open location> /boot/grub/ . i may be going about this in the wrong way. if so please instruct, i am not familure with linux.

Seve
25th August 2006, 03:01 AM
Hello:
You need to open a terminal and log in as root using
su -
yourpassword

then type
gedit /etc/grub.conf
Once you are done editing, save and exit.
You can read more of the FC/linux basics here : http://www.fedorafaq.org/basics/
and more about FC5 here : http://www.fedorafaq.org/

Seve

disruptiveent
25th August 2006, 03:34 AM
ok, that worked and i am now able to begin to boot windows. thanks alot. the prob now is that window dosn't make it to the desktop. there is a error. when i look in the logical volume manager from linux, it says for the windows partition the following:

Partition Type: Hidden HPFS/NTFS (0x17)
Mount Point: Unmounted
Mount Point when Rebooted: None
File System: No FileSystem

i'm not sure if the above has anything to do with windows not booting?

Seve
25th August 2006, 04:32 AM
Hello:
Fedora does not have native ntfs file support
First you need to know what kernel you are presently running and is it 32 or 64 bit?
open a terminal and type either or both of the following:
uname -r
or uname -a
You need to download and install the matching ntfs kernel ... you can do this from the livna repo
To enable it please do the following?
open a terminal and log in as root using
su -
yourpassword
type
mkdir /mnt/windows
enter
then type
cd /home/username
then copy and paste this
rpm --import http://rpm.livna.org/RPM-LIVNA-GPG-KEY
then type or copy and paste [assuming you are using 32 bit FC and kernel 2174 ..if otherwise choose the correct kernel from here: http://rpm.livna.org/fedora/5/i386/
wget http://rpm.livna.org/fedora/5/i386/kmod-ntfs-2.1.27-1.2.6.17_1.2174_FC5.i686.rpm

Once it is downloaded, type
rpm -ivh *.rpm
then while the terminal is open
type gedit /etc/fstab
and add this line to the end of your fstab file
/dev/sda1 /mnt/windows/ ntfs auto,umask=0222

Note:
sda1 is used as an example as you did not provide any other info?
to find out what disk you windows is installed on open a terminal and log in as root using
su -
yourpassword
then type
fdisk -l
Seve