PDA

View Full Version : Fedora refuses to login as user after yum update!



overule
17th August 2006, 01:27 PM
Hi,

I ran yum update and it went pretty well until i rebooted my computer. As usual the login screen appeared but i can't login as a normal user. I got the authentication failed message eventhough the username and password were correct. Having said that i was able to login as a root user. Next i opened up a terminal and ran



su myusername


I got the authentication failed message again. I did tried to change the password but it just didn't worked. Then, i tried to recreate another user account but i kept getting the authentication failed messages. The bottom line is that executing yum update destroyed my user account.

I thought that running yum update is the best way for a complete upgrade. What a disappointment !

Please share some lights of yours

thanks

dwisianto
17th August 2006, 01:29 PM
try ls -l /home/username
see if you have the right permission for your home folder
otherwise you can do
chgrp -R username /home/username
chown -R username /home/username

overule
17th August 2006, 01:35 PM
yeah, i have the correct permission but fedora just doesn't want to log me in. I have also executed the above instructions with no help.

overule
17th August 2006, 02:59 PM
After an intensive search, i found the solution.

GO to system | Administration | Authentication

uncheck Enable Winbind Support
chedk Local Authorization is suffiicent for local users

Updating to the latest kernel also destroyed ndiswrapper. :sigh: