PDA

View Full Version : Getting Error "fsck.ext3 Unable to resolve 'LABEL=boot'" during Booting of FC 4



salil.mehta
16th August 2006, 07:46 AM
Hi,

PROBLEM:
On Booting of (newly installed )FC4 just after successful initializaton of Hardware 'fsck' is launched which detects no errors but suddenly I see an ERROR being reflected after that...
"fsck.ext3 Unable to resolve 'LABEL=boot'"

DETAILS:

I have created a Dual Booting system between Windows XP and Fedora Core 4 on my Laptop (HP dv2000-SATA based HDD); such that NTLDR is launched first and Displays its OS Selection Menu (b/w Windows XP and FC4) and then on selecting FC4 GRUB Menu is launched.

Partitioning done is as follows-
sda1- Windows XP
sda6-/boot (ext3)~200 Mb
sda7-swap~2Gb
sda8-/ (ext3)~20Gb

Windows XP was installed first on "sda1" partition sector therefore NTLDR was already there on the MBR. I have installed GRUB on my Boot sector (sda6) rather than MBR.

Initialy, I had created a copy of my boot sector as "linux.bin" using command
"dd if=/dev/sda6 of=linux.bin bs=512 count=1"

Then copied linux.bin in my c: drive i.e sda1 and updated configuration file of NTLDR i.e boot.ini as follows-

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOW S
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /noexecute=optin /fastdetect
c:\linux.bin="Fedora Core 4"

Below is my menu.lst/grub.conf file-

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,5)
# kernel /vmlinuz-version ro root=/dev/sda8
# initrd /initrd-version.img
#boot=/dev/sda6
default=1
timeout=5
splashimage=(hd0,5)/grub/splash.xpm.gz
hiddenmenu
title Fedora Core 4 (2.6.11-1.1369_FC4)
root (hd0,5)
kernel /vmlinuz-2.6.11-1.1369_FC4 ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.11-1.1369_FC4.img
title Windows XP
rootnoverify (hd0,0)
chainloader +1


NOTE: I needed above style of booting so that my Windows XP is always in bootable condition and i could independently do programming of Linux Kernel
I am new to compilation of Linux Kernel and Kernel programming, this is to avoid messing up with Windows XP which is freaquently required for other for other purposes,


Please extend your helping hands...it is really urgent for me to solve this problem.


Thanks In Anticipation
Salil

dartman
17th August 2006, 12:46 PM
I need to preface this by saying that I am in no way a Linux expert. The error message "fsck.ext3 Unable to resolve 'LABEL=boot'" leads me to think that maybe the entry in your /etc/fstab for your boot partion is wrong. Mine says LABEL=/boot , your's might not have the forward slash in there. Is that the answer to your problem? I have no idea, maybe someone else w/ more knowledge could shed some light on it, but it might me a place to start.

salil.mehta
21st August 2006, 09:00 AM
Thanks!!

This was precisely whyit was happening...

It really came out to be a Trivial problem....I was able to solve it. Actually during installation I had given wrong LABEL=\boot to boot partition; it should have been LABEL=/boot.

This caused a mess up when "fsck" ran initially during startup; actually it was not able to recognize the boot partition by the LABEL name present within "fstab",since partition with LABEL=\boot never existed; what was existing LABEL=/boot.

I simply corrected LABEL name with "e2label" utility by going in "linux rescue" mode....and bing it worked....

Thanks for the help extended...

dartman
21st August 2006, 09:08 AM
Awesome! I'm really am really excited to know that you were able to fix the problem. Sometimes even the littlest things can bring a system to it's knees. I'm glad it worked out.

salil.mehta
21st August 2006, 09:10 AM
Thanks!! Bud....


--BIG THINGS ARE MADE BY COMBINATION OF SMALL-SMALL THINGS--