PDA

View Full Version : change repository for quick updates



grimmson
14th August 2006, 11:39 PM
Hello all. New to fedora and wanted to update my system quickly. Fedora servers seem to be working mighty hard. Downloaded fedora from ftp://ftp.gtlib.gatech.edu/ last noght with good speed. Is it safe smart and possible to update from ftp://ftp.gtlib.gatech.edu/pub/fedora.redhat/linux/core/updates/5/x86_64 ? Also had problems with regular repositories / updates. Got error messages. Is x86_64 a little buggy?

Jman
15th August 2006, 04:20 PM
What error messages exactly?

If the mirror seems to be regularly updated there should not be problems with using it, regardless of architecture. It's just a download site of rpms after all.

x86_64 is a little tricker due to having both 32 and 64 bit stuff, but I'm running it.

grimmson
15th August 2006, 07:31 PM
Seems like with a clean install some updates have to be done ing order. It seemed tile cups, hal and one lib "Broke" the update process. Wish I could be more spacific. Hey jman can you check my how to at http://forums.fedoraforum.org/showthread.php?t=120913 . I think it's good (from noob to noob) I did find a work around and it's posted there. Here's a hint for newbs out there
1) goto fedora.com pick a close mirror
2) open /etc/yum.repos.d/fedora-updates.repo with sudo gedit(or whatever type of repo needed, I wanted to change path to updates.)
3) follow mirror path (ftp if possable) to release version Mine was ftp://ftp.gtlib.gatech.edu/pub/fedora.redhat/linux/core/updates/5/x86_64
4) Use logic. compare fedora-updates.repo baseurl to the path in firefox (Hint $releasever means release versoun and $basearch is your 386, ppc or _64.
5) copy necessary entry [updates] for me and paste after last entry. replace base url with firefox address ( #baseurl=ftp://ftp.gtlib.gatech.edu/pub/fedora.redhat/linux/core/updates/5/x86_64 for me) make sure it's enabled enable=1
6) Disable original entry enable=0 and save
7) get updates w/ software updater
8) If you want after updates you can edit etc/yum.repos.d/fedora-updates.repo , disable tne new repo and re-enable default repo by changeing enable=?.

If any guru's think I'm wrong poease say something. I only think I know what i'm doing. Good day and good luck.

Jman
17th August 2006, 10:13 PM
So you did pick a mirror, and it worked.

You may also have luck installing yum-fastestmirror. It figures out some good mirrors for you.

grimmson
18th August 2006, 02:25 AM
Yep. download went from 20 - 40 kbpl to 120-160 kbps. That yum command would have been nice though. thanks.