PDA

View Full Version : problem with mplayer/tovid/yuv4mpeg



joa
13th August 2006, 07:32 PM
hi all,

i'd really grateful if any of you can give me some advice on this.

i'm trying to use tovid to convert an .avi file to .mpg. first, extracting audio works great, but i'm getting an error when tovid is trying to use mplayer to encode the video stream. basically, it seems to be a problem with the video output yuv4mpeg. tovid is asking mplayer to use yuv4mpeg to issue a .yuv file. mplayer is constantly crashing when tovid is doing this. it's basically related to the option "-vf-add scale=720x540" (where 720 and 540 can be any integers). when i try to run the command myself from a terminal, and when i leave this "-vf-add scale" out, everything works fine. basically the command:

mplayer -benchmark -nosound -noframedrop -noautosub -vo yuv4mpeg:file="video.yuv" -vf-add scale=720:544 -vf-add expand=720:576 "infile.avi"

i'm getting the error:

MPlayer interrupted by signal 11 in module: decode_video
- MPlayer crashed by bad usage of CPU/FPU/RAM.

causes mplayer to crash, but everything works when i leave "-vf-add scale" out.

i'm using FC4, and i've tried it both on my centrino laptop (with an IBM 855GM? video card) and on a desktop with an nVidia card. can anybody help me out here? i'd be really grateful for any advice!

mpolo
14th August 2006, 08:23 PM
The lastest mplayer build from livna seems to break the transcoding abilities of MPlayer... I just installed to /usr/local from source, and solved the problem -- I needed to convert some wmas to mp3 quick, so I went for the frowned-upon "go behind yum's back". If you're not using the latest build, I don't know...