PDA

View Full Version : Help a newbie get his integrated wireless working



extendedping
11th August 2006, 08:34 PM
ok my switch away from windows is almost complete,,,I have a hp pavillion 2050 dual booting fed 5 with xp and I am loving it BUT... I need a damm cable for linux and use the wireless for windows...I looked up under windows and see it has an intel 3945 integrated wireless...so I did a bit of searching and found this page... http://ipw3945.sourceforge.net/ which I am hoping holds the key to my linux liberation. however as a newbie I am having trouble installing the drivers for this card...first up on the requirements page it says I need

1. The binary microcode image, available here.
2. The binary user space regulatory daemon, available here.
3. The ieee80211 subsystem version 1.1.11 or newer.
4. Linux kernel 2.6.13 or newer. See README.ipw3945 for information on specific options required to be enabled in the kernel.
5. Wireless Extensions (v17) and Tools (v28)
6. For WPA you need a WPA supplicant compatible with the latest versions of the wireless extensions (v18 and newer).

ok I have no idea what these thing are (for instance which is the actuall driver?) or what i have to do to get th e whole smeband working...for instance I have the most updated kernal (thanks to yum) but when I downloaded the ieee80211 it failed saying I was missing files...

basically I am looking for real simple (think dummied down) explainations for what all these thing are and some help making sure I install these things correctly, and in the right order...this is very important to me as once I get this wireless working me and my laptop really get cooking and up to speed (I have like 5 new linux books waiting) and perhaps in the future I can even help people out here....so.....123 helppppppppppp

Iron_Mike
11th August 2006, 10:00 PM
ok my switch away from windows is almost complete,,,I have a hp pavillion 2050 dual booting fed 5 with xp and I am loving it BUT... I need a damm cable for linux and use the wireless for windows...I looked up under windows and see it has an intel 3945 integrated wireless...so I did a bit of searching and found this page... http://ipw3945.sourceforge.net/ which I am hoping holds the key to my linux liberation. however as a newbie I am having trouble installing the drivers for this card...first up on the requirements page it says I need

1. The binary microcode image, available here.
2. The binary user space regulatory daemon, available here.
3. The ieee80211 subsystem version 1.1.11 or newer.
4. Linux kernel 2.6.13 or newer. See README.ipw3945 for information on specific options required to be enabled in the kernel.
5. Wireless Extensions (v17) and Tools (v28)
6. For WPA you need a WPA supplicant compatible with the latest versions of the wireless extensions (v18 and newer).

ok I have no idea what these thing are (for instance which is the actuall driver?) or what i have to do to get th e whole smeband working...for instance I have the most updated kernal (thanks to yum) but when I downloaded the ieee80211 it failed saying I was missing files...

basically I am looking for real simple (think dummied down) explainations for what all these thing are and some help making sure I install these things correctly, and in the right order...this is very important to me as once I get this wireless working me and my laptop really get cooking and up to speed (I have like 5 new linux books waiting) and perhaps in the future I can even help people out here....so.....123 helppppppppppp

Open a terminal window switch user - "su -" that is "su dash" and type:

yum -ivh kernel-devel

For items 3,4,5 and 6 you don't have to do anything as they are supported natively in Fedora. The "microcode" is the firmware. Download it to your home directory, using your file browser doubleclick the file and it should ask you to extract it. Once that is down switch user "su" to root and go to the directory. Copy the files to /lib/firmware.

Next download the regulatory code which is the driver, download it to your home directory and using the file browser doubleclick it and extract the files. Then switch user "su" to root and change to the directory where the driver files are and run these commands:

make
make install

Reboot the computer open a terminal window and type:

iwconfig eth1

If everything went ok you should see your wireless card listed

extendedping
12th August 2006, 08:52 AM
hmm I tried the yum command, didn't seem to work but I did a yum install kernel-devel and it seemed to work..I downloaded the files, untarred them in my home dir and then went into the directories...for item 1 I copied the files into /lib/firmware. for item 2 I could not run any make commands on it but there was a file (green meaning its executalbe right?) called ixw3945d which was in the x86 directory (see it below)...

ipw3945d-start ipw3945d-stop LICENSE.ipw3945d README.ipw3945d x86 x86_64

looking at the readme file (see above) I copied teh ipw3945d file (again in the x86 directory)to /sbin which the readme file said would be the normal location. I then restarted the computer and ran iwconfig and got the following output

[root@fed5 x86]# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

sit0 no wireless extensions.

I'm sure I did something wrong but not sure what....thanks I need more help of possible...

bkat
13th August 2006, 09:29 PM
Start by adding livna to your yum repositories
$ rpm -ivh http://rpm.livna.org/livna-release-5.rpm

now install the ipw3945-firmware and the ipw3945d packages
$ yum install ipw3945-firmware ipw3945d

the last thing you need to install is the kernel module. That is what is available at the sourceforge link mentioned above

$ tar zxvf ipw3945-1.0.12.tgz
$ cd ipw3945-1.0.12
$ make
$ make install_for_testing

You can run the load script in the ipw3945-1.0.12 directory to load all the modules or have it done automically by editing /etc/modprobe.conf
alias eth1 ipw3945
install ipw3945 /sbin/modprobe --ignore-install ipw3945 ; sleep 0.5 ; /sbin/ipw3945d --quiet
remove ipw3945 /sbin/ipw3945d --kill ; /sbin/modprobe -r --ignore-remove ipw3945

extendedping
14th August 2006, 02:28 AM
Start by adding livna to your yum repositories
$ rpm -ivh http://rpm.livna.org/livna-release-5.rpm

now install the ipw3945-firmware and the ipw3945d packages
$ yum install ipw3945-firmware ipw3945d

the last thing you need to install is the kernel module. That is what is available at the sourceforge link mentioned above

$ tar zxvf ipw3945-1.0.12.tgz
$ cd ipw3945-1.0.12
$ make
$ make install_for_testing

You can run the load script in the ipw3945-1.0.12 directory to load all the modules or have it done automically by editing /etc/modprobe.conf
alias eth1 ipw3945
install ipw3945 /sbin/modprobe --ignore-install ipw3945 ; sleep 0.5 ; /sbin/ipw3945d --quiet
remove ipw3945 /sbin/ipw3945d --kill ; /sbin/modprobe -r --ignore-remove ipw3945


ok i loaded the lindva repo using the rpm command...

I then cut and pasted the yum install command for the 2 files and I got this message

[root@fed5 etc]# yum install ipw3945-firmware ipw3945d
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
livna [1/4]
core [2/4]
updates [3/4]
extras [4/4]
Reading repository metadata in from local files
Parsing package install arguments
No Match for argument: ipw3945-firmware
No Match for argument: ipw3945d

:(((( I take it this is not a good message...

bkat
14th August 2006, 02:37 AM
My bad, the ipw3945 rpms are at freshrpms,
rpm -ihv http://ftp.freshrpms.net/pub/freshrpms/fedora/linux/5/freshrpms-release/freshrpms-release-1.1-1.fc.noarch.rpm

Also you may also need to add
/sbin/ipw3945d --quiet

to /etc/rc.local

extendedping
14th August 2006, 03:21 AM
First off thanks for bearing with me on this...I am taking it step by step..I am up to the kernel module from sourceforge.net.
I took the file that said stable (not .12) hope that was ok. I untarred and went into the main directory and ran make and got this error message...

w3945-1.1.0]# make
sed: can't read /lib/modules/2.6.17-1.2174_FC5smpnet/ieee80211.h: No such file or directory

ERROR: A compatible subsystem was not found in the following path[s]:

/lib/modules/2.6.17-1.2174_FC5smp /lib/modules/2.6.17-1.2174_FC5smp/build

You need to install the ieee80211 subsystem from http://ieee80211.sf.net
and point this build to the location where you installed those sources, eg.:

% make IEEE80211_INC=/usr/src/ieee80211/

or use the 'make patch_kernel' within the ieee80211 subsystem to patch your
kernel sources.

make: *** [check_inc] Error 1

what it means I have no idea (:::::::

bkat
14th August 2006, 03:42 AM
you should have kernel-smp-devel installed (assuming you are running the SMP kernel)

$ yum install kernel-smp-devel

extendedping
14th August 2006, 03:43 AM
ok as I see it says i neet the ieee80211 thingamagigge I downloaded it untarred it went into the folder and ran make (this newbie is really flying blind)....I got this which is asking me if to hit yes or no to keep files...as I don't know if hitting one or the other will mess up my system I am leaving it opened pending more helpppppppppppppppppppp

[root@fed5 downloads]# cd ieee80211-1.1.14
[root@fed5 ieee80211-1.1.14]# ls
CHANGES ieee80211_crypt_tkip.c ieee80211_tx.c Makefile
GIT_SHA1 ieee80211_crypt_wep.c ieee80211_wx.c net
idvals ieee80211_geo.c INSTALL remove-old
ieee80211_crypt.c ieee80211_module.c in-tree
ieee80211_crypt_ccmp.c ieee80211_rx.c LICENSE
[root@fed5 ieee80211-1.1.14]# make
Checking in /lib/modules/2.6.17-1.2174_FC5smp for ieee80211 components...
find: /lib/modules/2.6.17-1.2174_FC5smp/build/: No such file or directory
/lib/modules/2.6.17-1.2174_FC5smp/kernel/net/ieee80211/ieee80211_crypt.ko
/lib/modules/2.6.17-1.2174_FC5smp/kernel/net/ieee80211/ieee80211_crypt_tkip.ko
/lib/modules/2.6.17-1.2174_FC5smp/kernel/net/ieee80211/ieee80211.ko
/lib/modules/2.6.17-1.2174_FC5smp/kernel/net/ieee80211/ieee80211_crypt_wep.ko
/lib/modules/2.6.17-1.2174_FC5smp/kernel/net/ieee80211/ieee80211_crypt_ccmp.ko
Above files found. Remove? [y],n

bkat
14th August 2006, 05:31 AM
you shouldn't have to compile ieee80211. Everything except the ipw3945 kernel module is available for installation via yum. The ieee80211 stuff is part of the kernel-smp-devel package. Just install that via the yum command from a few posts ago and then compile the ipw3945 kernel driver.

extendedping
16th August 2006, 05:13 AM
ok thanks all I have been away for a few days and am continuing in my wireless quest. here is what I am up to...I have downloaded the 2 files mentioned via yum install ipw3945-firmware ipw3945d. I have updated via yum install kernal-smp-devel. I have downloaded this file ipw3945-1.1.0.tgz and untarred it, gone into the main dir and run make (which did something) and make install and make install_for_testing, both which ended saying use the load commands...now BKAT said I could do this
You can run the load script in the ipw3945-1.0.12 directory to load all the modules or have it done automically by editing /etc/modprobe.conf
alias eth1 ipw3945
install ipw3945 /sbin/modprobe --ignore-install ipw3945 ; sleep 0.5 ; /sbin/ipw3945d --quiet
remove ipw3945 /sbin/ipw3945d --kill ; /sbin/modprobe -r --ignore-remove ipw3945
Reply With Quote

which as a newbie is like impossible for me or run the load scrip. so I ran the load scrip and was able to then see what I hope is a good wireless card running ifconfig eth1. I then went into the xwindow network configuration and see entries for both eth1 (wireless) and eth0 (ethernet) showing as active on the first tab called devices. I was able under edit eth1 to put in ipaddress and gateway (my linksys router) as well as to go into a wireless tab where I put ad hoc for mode (which matches my router) and ssid name which matches my router and a key which I had on my router as well. I see my router has a wireless channel of 7 - 2.442HGz so I put my wireless channel to 7....and put my transmit rate to auto which is what i see it says under advanced wireless settings on my router...now running ifconfig eth1 here is my output

[root@fed5 ipw3945-1.1.0]# ifconfig eth1
eth1 Link encap:Ethernet HWaddr 00:13:02:48:4F:30
inet addr:192.168.1.7 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::213:2ff:fe48:4f30/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:160 errors:5 dropped:13066 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:92 (92.0 b) TX bytes:73440 (71.7 KiB)
Interrupt:185 Base address:0xa000 Memory:d4000000-d4000fff

and running iwconfig eth1 seems to give more info as well as a scary warning message

[root@fed5 ipw3945-1.1.0]# iwconfig eth1
Warning: Driver for device eth1 has been compiled with version 20
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...

eth1 IEEE 802.11g ESSID:"spider" Nickname:"fed5"
Mode:Ad-Hoc Frequency:2.442 GHz Cell: 02:13:02:BA:97:D5
Bit Rate:54 Mb/s Tx-Power:15 dBm
Retry limit:15 RTS thr:off Fragment thr:off
Encryption key:4242-3539-3645-3446-3742-0000-00 Security mode:open
Power Management:off
Link Quality:99 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:13477 Missed beacon:0



so at this point I got hopefull and tried to ping my linksys 192.168.1.11 but it failed...hmmm so next I put in my cable, activate my regular ethernet and go onto the linksys and try to ping (with a cable again) the wireless at 192.168.1.7 and it does work though obviously throught the regular eth0 interface... so basically I don't know what to do....a few other points..my linksys says it is using WEP 64 bit encryption but I don't see any place to put this setting if I need it on my fedora laptop...also the second tab under the fedora network configuration tool HARDWARE shows "intel corp unknown device 1092 / eth0 but I don't see anything for an eth1 wireless or anything like intel ipw3945...and under NEW on the hardware tab after selecting hardware type wireless there was no entry in the dropdown list for the intel ipw3945...though under Devices-Edit-Hardware Devices (hardware devices drilled down to from the devices tab, not the jjust mentionedsecond overall tab which says Hardware)I see eth1 (the wireless) bound to mac address 00:13:02:48:4f:30 which is know is correct because I looked up the mac in xp................

Sorry for the length as I am not exactly a pro at this I am trying to give as much info as I can as I am not sure what is important or not in getting this thing working.........HHHHHHHHHHEEEEEELLLLLLLLLLLLLLLLPP PPPPPPPPPPPPP:))))))))))))))))))))))))))))))))

extendedping
17th August 2006, 04:05 AM
Its so close to working........so close......

extendedping
17th August 2006, 05:18 PM
Any suggestions to what I am doing wrong here? Also does fedora have any graphical wireless utilities available I should know about apart from the wireless tab on the netwoking configuration? For instance is there anything like in xp where you can see (or attempt to see in my case) all the wireless networks withn range???

extendedping
18th August 2006, 01:10 AM
:(((((((((((((((((((((((((((((((((((((((((((((

extendedping
30th August 2006, 01:07 AM
Double

:(
:(

extendedping
31st August 2006, 01:31 PM
ok so I quit trying to get the integrated wireless working can any forum member suggest a pcmcia card that should work with fedora 5?

rappermas
1st September 2006, 05:11 AM
Whoa, easy there. Before you give up altogether, try PCLinuxOS. It usually does a very good job detecting wireless.

That's what I use now because Fedora had so much trouble with my wireless. Also, PCLinuxOS has some nice candy, comes with a lot of stuff out of the box, and is a nice distro overall, despite the fact that it isn't exactly as mainstream as something like say, SuSE or Red Hat. With luck, you should be able to get this working. Unless you want to use Fedora, in which case, I really can't blame you because there are a LOT of things about Fedora that I LOVE.

extendedping
1st September 2006, 05:51 AM
thanks for the suggestion, I am not sure what to do yet, I can't beleive the linux leader (redhat or fedora) is this hard to get wireless working...well..I think its the leader anyway...:)