PDA

View Full Version : Kernel upgrade problem



symbiat
8th August 2006, 05:01 PM
I recently used software updates to upgrade from the 2139 to the 2157 kernel, but the new kernel does not appear in the list of kernels at the boot prompt.

/boot and yaboot.conf look OK:

# ls -al /boot
drwxr-xr-x 5 root root 1024 Jul 17 05:36 .
drwxr-xr-x 23 root root 4096 Aug 8 2006 ..
-rw-r--r-- 1 root root 61371 Jun 23 13:22 config-2.6.17-1.2139_FC5
-rw-r--r-- 1 root root 61374 Jul 11 23:37 config-2.6.17-1.2157_FC5
drwxr-xr-x 2 root root 1024 Aug 8 11:25 etc
drwxr-xr-x 2 root root 1024 Jun 15 05:01 grub
-rw-r--r-- 1 root root 2147676 Jun 25 06:13 initrd-2.6.17-1.2139_FC5.img
-rw-r--r-- 1 root root 2147705 Jul 17 05:36 initrd-2.6.17-1.2157_FC5.img
drwx------ 2 root root 12288 Mar 30 19:10 lost+found
-rw-r--r-- 1 root root 829264 Jun 23 13:22 System.map-2.6.17-1.2139_FC5
-rw-r--r-- 1 root root 829538 Jul 11 23:37 System.map-2.6.17-1.2157_FC5
-rwxr-xr-x 1 root root 4048568 Jun 23 14:12 vmlinuz-2.6.17-1.2139_FC5
-rwxr-xr-x 1 root root 4056760 Jul 12 01:01 vmlinuz-2.6.17-1.2157_FC5

# cat /boot/etc/yaboot.conf

# yaboot.conf generated by anaconda
boot=/dev/sda2
init-message=Welcome to Fedora Core!\nHit <TAB> for boot options

partition=3
timeout=80
install=/usr/lib/yaboot/yaboot
delay=5
enablecdboot
enableofboot
enablenetboot
magicboot=/usr/lib/yaboot/ofboot

image=/vmlinuz-2.6.17-1.2157_FC5
label=2.6.17-1.2157_F
read-only
initrd=/initrd-2.6.17-1.2157_FC5.img
root=/dev/VolGroup00/LogVol00
append="rhgb quiet"

image=/vmlinuz-2.6.17-1.2139_FC5
label=2.6.17-1.2139_F
read-only
initrd=/initrd-2.6.17-1.2139_FC5.img
root=/dev/VolGroup00/LogVol00
append="rhgb quiet"

Probably the software update missed an important step? So how can I boot the newest kernel and make it appear as the default in the bootloader? This is a G3 B&W PPC machine with SCSI disks.

lazlow
8th August 2006, 06:11 PM
Probably best to just: yum update kernel (in a terminal as root). Reduces the chance that something was corrupted by updater.

lazlow

Seve
8th August 2006, 06:27 PM
Hello:
Have a look in your /lib/modules to make sure that everythiing is there?
You may have to or any rate you could to do a [to get an initrd]
# mkinitrd /boot/initrd-2.6.17-1.2157.img 2.6.17-1.2157

Seve

symbiat
9th August 2006, 03:00 PM
Hello:
Have a look in your /lib/modules to make sure that everythiing is there?
You may have to or any rate you could to do a [to get an initrd]
# mkinitrd /boot/initrd-2.6.17-1.2157.img 2.6.17-1.2157


Hmmm...

# /sbin/mkinitrd /boot/initrd-2.6.17-1.2157.img 2.6.17-1.2157
No modules available for kernel "2.6.17-1.2157".
# ls -al /lib/modules/2.6.17-1.2157_FC5/
total 1124
drwxr-xr-x 5 root root 4096 Jul 17 05:36 .
drwxr-xr-x 4 root root 4096 Jul 17 05:36 ..
lrwxrwxrwx 1 root root 46 Jul 17 05:35 build -> ../../../usr/src/kernels/2.6.17-1.2157_FC5-ppc
drwxr-xr-x 2 root root 4096 Jul 11 23:37 extra
drwxr-xr-x 10 root root 4096 Jul 17 05:35 kernel
-rw-r--r-- 1 root root 225769 Jul 17 05:36 modules.alias
-rw-r--r-- 1 root root 69 Jul 17 05:36 modules.ccwmap
-rw-r--r-- 1 root root 220343 Jul 17 05:36 modules.dep
-rw-r--r-- 1 root root 813 Jul 17 05:36 modules.ieee1394map
-rw-r--r-- 1 root root 375 Jul 17 05:36 modules.inputmap
-rw-r--r-- 1 root root 11312 Jul 17 05:36 modules.isapnpmap
-rw-r--r-- 1 root root 672 Jul 17 05:36 modules.ofmap
-rw-r--r-- 1 root root 153980 Jul 17 05:36 modules.pcimap
-rw-r--r-- 1 root root 799 Jul 17 05:36 modules.seriomap
-rw-r--r-- 1 root root 105301 Jul 17 05:36 modules.symbols
-rw-r--r-- 1 root root 289970 Jul 17 05:36 modules.usbmap
lrwxrwxrwx 1 root root 5 Jul 17 05:35 source -> build
drwxr-xr-x 2 root root 4096 Jul 11 23:37 updates
#

zorro
11th August 2006, 03:27 AM
Don't forget the "_FC5"

/sbin/mkinitrd /boot/initrd-2.6.17-1.2174_FC5.img 2.6.17-1.2174_FC5

:-)

symbiat
11th August 2006, 06:34 PM
If you recall from the earlier listings, I already have an initrd, so not surprisingly I get this:

# /sbin/mkinitrd /boot/initrd-2.6.17-1.2174_FC5.img 2.6.17-1.2174_FC5
/boot/initrd-2.6.17-1.2174_FC5.img already exists.
#

zorro
12th August 2006, 01:11 AM
I suggest you rename your existing initrd file to something else - maybe append a .old to it. Mkinitrd will then produce a new file for you.

You could add a -f flag to the mkinitrd call to force it to overwrite the existing file but I wouldn't recommend it!

ppesci
15th August 2006, 09:27 PM
Please, only run:

ybin

that's all

Pietro Pesci Feltri

Sohbet
21st August 2006, 07:57 PM
Symbiat, post: #6 Thanks.

savel
17th September 2006, 11:01 AM
I noticed that selinux policy (in enforcing mode) doesn't allow yaboot to update kernel files
I opened a bugzilla https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=206789