PDA

View Full Version : 2.6.17-1.2157_FC5/build: No such file or directory. Stop.



Scrib
6th August 2006, 06:37 PM
Hi,

I'm trying to install spca5xx-20060501 to make my web cam work but I'm getting the following error messagr below when i make file. This is a fresh install of Fedora 5 and I'm running as root. I had a simular message when trying to install something else a few weeks ago. Anyone any ideas?

[root@localhost spca5xx-20060501]# make
Building SPCA5XX driver for 2.5/2.6 kernel.
Remember: you must have read/write access to your kernel source tree.
make -C /lib/modules/`uname -r`/build SUBDIRS=/root/software/WebCam/spca5xx-20060501 CC=cc modules
make: *** /lib/modules/2.6.17-1.2157_FC5/build: No such file or directory. Stop.
make: *** [default] Error 2

Astarta
6th August 2006, 07:23 PM
This means that the sources of your running kernel (2.6.17-1.2157_FC5) are not installed. So you sould install kernel-devel-2.6.17-1.2157 rpm package to get this working.

vnpenguin
6th August 2006, 07:31 PM
Just do "yum -y install kernel-devel"

Scrib
7th August 2006, 12:21 PM
Thanks guys.

Do i have to download anything (i.e. the kernel-devel-2.6.17-1.2157 rpm) before i run "yum -y install kernel-devel"?
Or can i just run it as is (not at the box today to try it you see) ?

tw56
7th August 2006, 02:53 PM
The yum command will download and install for you. In terminal do:
su -
type your password for root
then type the yum command given above.

Scrib
8th August 2006, 08:59 AM
Thanks guys worked a treat.

Ran the spca5xx install ok with no errors. Got a picture from my Creative NX webcam and then the system freezes. Rebooted a few times with no luck - same problem.

I'll check into this on the forums, unless anyone has an idea?

Astarta
8th August 2006, 09:11 AM
Not sure what Creative NX webcam installs, but seems like it compiles a kernel module (as it needs kernel sources).
Find this module and load it separately (using 'modprobe'), check whether there are any errors while loading.
Also It's mot clear, what exactly freezes - kernel or application.

Scrib
8th August 2006, 09:41 AM
Sorry - the whole thing. No mouse movement or keyboard access. I have to press the magic button to reboot it.

I'll try the modprobe and let you know.