PDA

View Full Version : Upgrade problem



seshomaru samma
6th August 2006, 07:01 AM
Hi
trying to upgrade from FC4 to FC5
i know it's not recommended but ....
anyway , i followed this guide (http://fedoraproject.org/wiki/YumUpgradeFaq)

and when i do this :

[sesho@fedora ~]$ rpm -Uhv http://download.fedora.redhat.com/pub/fedora/linux /core/5/i386/os/Fedora/RPMS/fedora-release-5-5.noarch.rpm

i get this:

Retrieving http://download.fedora.redhat.com/pub/fedora/linux/core/5/i386/os/Fed ora/RPMS/fedora-release-5-5.noarch.rpm
error: Failed dependencies:
fedora-release = 4 is needed by (installed) yum-fedorafaq-4-2006.02.03.n oarch

what should i do?
:confused:

u-noneinc-s
6th August 2006, 07:49 AM
I was going to suggest removing fedora-release-4 first, but I see it's complaing about yum-fedorafaq-4. I would suggest going to the fedorafaq page and DL the fedorafaq yum config for fedora 5 and put in in an empty dir then DL fedora-release-5-5 and put it in the same dir. cd to that dir and do rpm -Uvh *.rpm. That should upgrade them both at the same time. then you can delete the rpms (if you want to).