PDA

View Full Version : Installed Fedora on maxtor HD, Now can't boot to raid 0 with winXP



tskochanski
6th April 2004, 08:38 AM
I just installed Fedora on my c: drive and it works great. However when I go into the bios and switch the system so that it boots winXP from my e: drive (which is a raid 0) the system ends up at a screen that says "press a key to reboot."

I've tried using winXP cd to do a repair install but from the install menu my e: drive is not recognized only the c: drive.

Did something that I did during the fedora installation on c: cause my computer not to recognize my raid 0 drive on e:?

my system:

asus a7v-133
1.4 amd t-bird
512 pc133 ram
2 ibm 30-gig hard drives in raid 0 (e: drive)
old maxtor 6 gig hard drive (c: drive)
radeon 7000 64 mb

kbradl1
6th April 2004, 02:32 PM
I don't think the fedora install would mess up your raid 0 drive.

Did you install windows then later add the maxtor drive? If so you may need to remove the maxtor to get windows to boot and update the boot.ini

I would recommend partitioning the raid 0 drive and installing both Fedora and windows on that. Use the maxtor as a slave drive to store MP3s or something.

Prometheus
7th April 2004, 03:06 PM
ALso, did you load a boot loader when you installed Fedora? The default position for the bios to look for the MBR is on c: drive. Even if you change the boot order, the bios still looks there. If there is nothing pointing to your raid drive that says "boot here" (exaggeration but you get the idea) it wont boot. Also, the raid drive may be first in the boot order, but if it has not MBR, it wont boot either. Make sure that you have grub/lilo installed on the primary disc (what ever one is hdd0 in the bios) and go from there.

tskochanski
7th April 2004, 05:09 PM
Would you be willing to walk me through it a bit? I had WinXP on the E: drive which is my raid0. I also had the C: the old maxtor hooked up but did'nt really use it. When I downloaded the three fedora disks I just formated the C:, loaded them on and changed the boot order in my bios from E: to C: and fedora started right up. However after playing with that for a while I restarted, entered the bios and changed the boot order back to E: (ATA100) but could not boot my E: drive and haven't been able to ever since. Actually I would be happy tossing the C: drive in the trash and just setting up a partition on E: and having both fedora and WinXP on E:

Prometheus
7th April 2004, 05:14 PM
when you installed fedora, did you install a boot loader (GRUB0? and if so, which drive did you install it on? The boot loader needs to be on your primary drive, that way you can pick which os you use on start up, and not have to go into the bios to do it. also, is XP NTFS? it shouldnt matter, but just trying to be through.

Basically, when you install FEdora, the drive you install it on should be set to slave. When you install GRUB (the boot loader) it will ask you where to put it, and it usually goes into the MBR on the primary disc (in your case the SATA drive). The SATA drive (with windows on it) should be set to hdd0 (primary) and the fedora drive (hdd 1 or 2 prolly) should be set second in the boot order. Now, when you boot, the bios should load GRUB which is located in the MBR on the SATA drive. You will then have the option of booting from either Windows or Fedora. Hopefully this works for you.

Most likely, you will just need to install GRUB on the MBR of the SATA drive or the drive with Fedora (put it on whichever one is primary) From there, you should be able to dual boot. Good luck, any more questions you know where to come.

tskochanski
7th April 2004, 05:58 PM
I don't think I installed the grub0 boot loader. Is it on disk one? Is there a way to do this after the fact? When I boot to the C: drive there is no option regarding OS, it just loads up fedora. Would it be possible and maybe best, since my c: maxtor is so slow, to just reformat the c: then load fedora onto my RAID0 with winXP?

Tim

Prometheus
9th April 2004, 02:24 PM
I would suggest wiping the c: drive as you just said. Then, put your raid drive as master (primary boot) and set your ide hdd up as slave (i think, not positive, its supposed to be slave with 2 ide hdds, so id do slave) and make it second boot device. (both of which should go after cd rom drive... so the boot order should be floppy, cd rom drive, raid0, hdd0 or 1 based on whatever # hdd it is). Then at this point, put the fedora discs in and begin the install. Fedora should recognize that xp is there, and ask you about GRUB. It will put it in the MBR on raid0 by default, but if it doesnt, tell it to install there. Then continue the install. You dont have to do anything to change to boot order. The next time you boot, it should load the boot loader and give you options for booting.

You can put both XP and Fedora on the same hdd however. This makes me a little uneasy, but many people do it and it works fine. I suggest partitioning it from xp, using partition magic or something similar. When you install fedora, the install directory will then be hda2 (i think, im not sure the letter config for raid, and 2 for second partition) it will again ask you where to install the boot loader, and again put it in the MBR on the raid0 hdd. You should be set. If windows is on a NTFS partition, you will have to format it from windows first. Maybe not have to, bad choice of words, Fedora can do it, but it is very unreliable with NTFS partition. I suggest doing all your partioning from windows if putting both os's on the same drive.

there is a way to install grub after the fact, but its not the easiest thing to do. I would just do a fresh install

Good luck, and may the force be with you.

tskochanski
9th April 2004, 08:10 PM
I removed the c: drive and booted from cd with disk 1 of fedora in. It installed all three disks on my e: raid drive. but when I went to boot the screen just gives me a GRUB prompt on a frozen screen. The keyboard doesn't work.

Prometheus
9th April 2004, 08:40 PM
make sure that the keyboard is set up as a ps2 or usb, depending upon which you have

tskochanski
21st April 2004, 08:32 PM
I have been posting to several other forums trying to get this figured out and am still stuck. Right now my main priority is to just get my raid 0 e: drive with winxp and all my stuff working. I'll worry about fedora later when I have a buddy over here to help me get the install right. I also have winxp installed on the c: drive now. Here's the latest...

okay, i just reinstalled my raid drivers and now when i boot winxp from the c: drive I can see my e: drive under disk management. This is how it looks:

disk 0, basic, online =>
c: 6gig NTFS healthy(system)

disk 1, basic, online =>
?:102mb healthy (active),1020mb healthy(unknown partition), 75.59gig (unallocted)

Are the first two parts of disk 1 likely my fedora partitions? should i just delete those partitions and see if it boots to winxp on the raid0 e:?

TS

imdeemvp
21st April 2004, 10:57 PM
i would say start from scratch! BUT remember to do a back up of your important documents or data....i hope this helps!

1st XP
2nd FC1

problem solve....i think :D

Prometheus
21st April 2004, 11:26 PM
The unknown partitions are probably the FEdora partitions, or maybe a corrupted file allocation table (thats what happened to mine, when i went to fix the MBR it screwed up the whole file system). Before completely deleting the c: drive, try unplugging it and see if the computer boots from the raid drive. If it boots from that, youre all set, just set the IDE to slave and go from there. Then you can delete the partitions or whatever. Im going to have to reinstall Fedora completely (to fix the corrupted file system i had to wipe both drives), then im gonna completely isolate them on separate drives and not even try to dual boot. Theres a think called NickLock that switches hard drives, but if you have a western digitial it complicates things and only runs at ata33. Just something to think about. Hope you get it up and the way you like it soon. May the Force be with you.