PDA

View Full Version : fstab



CardsRF
28th July 2006, 11:58 PM
FC5 problem. All devices mount successfully on boot up except for Suse. I have to manually mount Suse with <mount -a> everytime. The identical fstab entry works fine in Ubuntu. Is there a solution?

Here's my fstab:

LABEL=/ / ext3 defaults 1 1
devpts /dev/pts devpts gid=5,mode=620 0 0
tmpfs /dev/shm tmpfs defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs defaults 0 0
/dev/hdb2 swap swap defaults 0 0
/dev/hdb5 /media/Suse reiserfs acl,user_xattr 0 0
/dev/hdb6 /media/SuseHome reiserfs acl,user_xattr 0 0
/dev/hda1 /media/XP ntfs nls=utf8,umask=0222 0 0
/dev/hdb3 /media/Dapper ext3 defaults 0 0

Jongi
29th July 2006, 12:30 AM
I suspect it has something to do with the fact that your SUSE partition is a reiserfs partition. FC doesn't officially support reiserfs. I'll try to find what you need to do.

EDIT: Does the SUSE home partition mount?

EDIT2: Have you got reiserfs-utils installed? I'm not sure from which repo it is. It's installed on mine because my fedora partition is a reiserfs.

# yum list reiserfs-utils

if the output does not show it as installed (but shows it),

# yum install reiserfs-utils

CardsRF
29th July 2006, 01:07 AM
Thanks - I installed reiserfs-utils, rebooted, then got the same start-up message: mount operation not supported.
As usual, Suse did not mount automatically. I had to do it manually - <mount -a>

After reviewing the documentation, it looks as if reiserfs-utils corrects major problems. All the command line options modify the reiser flle system. I just want fstab to work when I boot Fedora.

ccrvic
29th July 2006, 01:23 AM
I just want fstab to work when I boot Fedora.

Does your initrd contain enough to mount reiserfs partitions?

Vic.

Jongi
29th July 2006, 01:25 AM
http://www.fedoraforum.org/forum/showthread.php?t=100302&highlight=reiserfs+support

Mot likely the SELinux issue described there.

CardsRF
29th July 2006, 01:54 AM
Problem solved. Thanks