PDA

View Full Version : Fedora Core 5 Core Repository Problems



newb23
28th July 2006, 08:13 PM
Hello, I'm extremely new to Linux and am having four problems. Please understand that I've already spent two days trying to figure this out. I will not have an internet connection on Fedora until I can install the drivers for my wireless internet card (Intel 3945).

1. a.- When I start Add/Remove Software it runs an error "Unable to retrieve software information", I've alread disabled the updates and extras and I can't think of anything else.
b.- When I try to get a .rpm file (such as WINE) to install the Installing Packages
window comes up but when I click install it runs the "Unable to retrieve software information" error and closes the window.

2. While going over installation information for the wireless driver (ieee802.1.1.12) if found a statement the said, "If <a command I tried that didn't work> doesn't work then you need the kernel source packages for the particular Linux distribution.

3. When I attempt to run installs using YUM in a terminal it gets to the repositories (core) (and again I've already got updates and extras disabled) and runs the error "Cannot find a valid baseurl for repo: core"

Please be merciful to the noob and help me out. :eek: :eek: :eek: :eek:

bob
28th July 2006, 08:41 PM
Well the Add & Remove Software glitch is known in FC5 and here is a workaround when you don't have internet access: http://www.city-fan.org/tips/YumRepoFromImages

I'll see if I can poke around and find anything on that wireless card (hard-wired myself) but someone else will probably have a quicker answer.

bob
28th July 2006, 09:21 PM
Okay, here's one place (mirror) that you can download the kernel-devel for kernel 2.6.15-2054 : ftp://mirror.linux.duke.edu/pub/fedora/linux/core/5/i386/os/Fedora/RPMS Of course, if you've somehow updated your kernel, use the mirror site and search Updates for the kernel-devel for your particular one.

Also, here's a thread that should be helpful: http://forums.fedoraforum.org/forum/showthread.php?t=29659

newb23
28th July 2006, 11:33 PM
Okay, the first part I've seen and tried to use I'll retry again and I'll also check out the second thanks and I'll update you as of my situation in a day or two.

Thanks again.

newb23
29th July 2006, 06:32 AM
Okay I think I'm catching on...does the link you gave cover a repository fix for the core or is that only for the internet? The repository fix isn't very specific... do I only use /ect/yum.repos.d or the entire reference to the repo = /ect/yum.repos.d/fedora-core.repo
and for .iso mounting do I reference the disk that I burned the FC5 .iso onto or reburn the .iso as a file instead of the disk image and reference that?