PDA

View Full Version : SATA RAID partition issue



blackrabbit
26th July 2006, 06:17 PM
I have this Silicon Image SATA RAID controller and Fedora 6 test_1 running on some older IBM P3 based server. The setup is simple mirror of 2 300Gb SATA drives.
The dmsetup sees the two drives in mirror and two respective devices present:

/dev/dm-0
/dev/mapper/sil_agahdicbfhcg

Everything seems to be okay so far. Now I would like to create a partition on that mirror with fdisk - it does seem to work:
fdisk> p
/dev/mapper/sil_agahdicbfhcg1 blablabla...

and when I try to save the partition table:
fdisk> w
WARNING: Re-reading the partition table failed with error 22: Invalid argument.
The kernel still uses the old table. The new table will be used at next reboot.

But guess what - after reboot there is no partition.
Ok, I created the same with parted. And parted works for some reason - it does create respective device link to that partition:
/dev/mapper/sil_agahdicbfhcgp1 (if i create partition on /dev/dm-0, it creates the link /dev/mapper/dm-0p1, but its the same)
also, some new device shows up: /dev/dm-1.
Ok, I creatred the filesystem and thought that its works now. But after reboot - its gone - no more device link to partition, not under /dev nor /dev/mapper.
If i take fdisk I can see that partition is intact but it is not linked. Why?
I can take parted, toggle some setting (like RAID ON) and the exit and it created the link again, but it never stays after reboot. What is wrong, what I am doing wrong? Tried to read docs but cant get a clue :(
Thanks in advance!