PDA

View Full Version : Missing a ton of permissions



cypher543
22nd July 2006, 07:34 PM
I like the Eclipse SDK, so I installed it with Fedora Core 5. Then I ran it's update application to install the C/C++ Development Toolkit. When the download was done, it gave me an error about not being able to write to Eclipse's plugin directory becuase it belongs to root.

This also happens with almost every other application. They all belong to root. :( Is there any way to make them all belong to my user account so I don't have to login as root each time I want to install a skin for XMMS or download a plugin for Eclipse?

djselbeck
22nd July 2006, 11:58 PM
Hello,

your problem is i think, that you installed eclipse as an rpm file. So you must install the c++ plugin also as an rpm. I prefer the yumex tool for this. If you doesn't have yumex installed you should install it with
yum install yumex and then under Applications-System...-> yumex you have a very good graphical tool for package management.

DJSelbeck

cypher543
23rd July 2006, 12:07 AM
The CDT plugin is only available through it's update site which must be run from within Eclipse. That's the impression I got, anyway. Since they didn't offer a RPM.

FedoraUK
23rd July 2006, 12:19 AM
You can use chown. "chown <username>:<usergroup> file". Try it with eclipse to see if it works.

Or how about chmod?

cypher543
23rd July 2006, 01:14 AM
Is there a way to CHOWN every file in every subfolder of a directory? Becuase there's a lot of folders and files I would need to run that command on. :(

FedoraUK
23rd July 2006, 01:37 AM
yes, use the -r switch. It stands for "recursive". so it's "chown -r".

when you use chown or chmod on a directory don't put the "/" after it.

"chown --help" will list a few more options too.

cypher543
23rd July 2006, 02:12 AM
Thanks! That worked great! Except that it's supposed to be an uppercase R. But whatever. :p

djselbeck
23rd July 2006, 03:53 PM
Hello, you could also install it with


yum install eclipse-cdt

DJSelbeck

cypher543
23rd July 2006, 03:57 PM
Heh, yeah... I noticed that while searching on Google yesterday. It was too late to try it, though, because Eclipse was already updating. Thanks, though. :D