PDA

View Full Version : Yum didn't update anything...



cypher543
22nd July 2006, 06:24 AM
I just installed Fedora Core 5, so I did a yum update. It downloaded 307 packages at a total of 638MB. When it was finished, it gave me an error about being unable to download the updated kernel becuase it had run out of mirrors. It had been giving errors on the kernel package saying that the filesize was wrong on every mirror it tried. Anyway, when it was done, it just quit with a message about new mail. But it didn't actually UPDATE anything. There was no "Installing" messages. It just stopped running as soon as the downloads were finished.

So I ran yum update again, but it wants to download all 307 packages again. I can't do that again becuase my ISP has a download limit and I'm almost maxed out for the month.

Is there anything I can do? Or do I just have to wait until August and try it again?

cypher543
22nd July 2006, 03:31 PM
A little update on my problem:

I did the following commands in a terminal, becuase I'm trying everything I can possibly can before I have to download 638MB again...


cd /var/cache/yum/update/packages/
yum localupdate *.rpm

It started examining the local files, running a transaction check, etc. But then it gave me a list of files to be updated and ended by asking if I would like to download 1.7 GIGABYTES!!

No... simply, no. I'm not downloading 1.7GB. I ran the freakin localupdate command to update from files I already downloaded, but instead, yum completely ignores it and decides to do whatever it freakin wants to. (I'm finding it very hard to censor myself, atm).

What the heck am I supposed to do?

cypher543
22nd July 2006, 03:53 PM
Erm... heh... yeah. Sorry for the triple post. It seems that it was trying to do a local update, actually. Yum should really say something other than "Total Download size:". Because then it just makes people think that it wants to download something (like me).

Anyway, so I ran the localupdate command again, decided to go ahead and download the packages, but instead it started updating them. But, still, a note to the developers: Use more descriptive text.

FedoraUK
22nd July 2006, 04:00 PM
Yum does seem a little cryptic in its descriptions.

edit: bugzilla was wrong term to use. Anyway is this the correct site? http://linux.duke.edu/projects/yum/

cypher543
22nd July 2006, 04:20 PM
Thanks for the link. I'll submit a bug report for it as soon as I can download Thunderbird (I have to check my email for the password).