PDA

View Full Version : I'm so ashamed that I am this dumb.



Robyn
21st July 2006, 04:45 PM
Hi. I have a very basic need. I'm a grad student and I need to analyze my data using a program that runs in linux and requires mysql database action.

So I decided that my laptop can have a partition for linux and all will be well. I've dabbled in knoppix (who hasn't?). I'm normally quite computer literate- I can build a system etc, but I'm no programmer.

So I had a friend install Fedora 4/bordeaux on my laptop. It runs fine, I guess.
I can't find any evidence of the mysql package i selected as being installed, and i can use navicat to be a client but needed to also be server (yes, same puter) too.

I just need to install all the stuff to do this. I got the famed "unable to retrieve software information" error when trying to open an .rpm or at add/remove software. So I followed advice i found online and tried to use Yum.

In the terminal i typed "mv -f yum.conf yum.conf.bak" I don't know what it meant, but yum doesn't work and now instead of the unable to retrieve... error I get exception occured and it "no such config file /etc/yum.conf"

Did I change something to point to a file I don't have? I think I may have.
This computer does NOT have internet access (the computer in question). Linux hates my wireless card and the wired net is strictly regulated here. (i can wait until i go home i guess but would like to get this taken care of at work where I'm productive)

Can one use YUM without internet? further searching assumes i have it.
I can be reached via aim at nefelejtsa in addition to here.

paul_b
21st July 2006, 04:56 PM
you need to do

mv -f /etc/yum.conf.bak /etc/yum.conf

and yum will work again.

yum requires the internet to resolve dependancies, but you should be able to do

yum localinstall [rpm name here]

and that will install the rpm, but you will probobly won't be able to do that unless your dependancies are installed.

Robyn
21st July 2006, 05:06 PM
Okay, I undid my thing. Now, how can i install things I have the rpm for without internet?

i CAN copy things to disk from internet and move them over. However the packages won't self-install without giving me that unable to retrieve stuff.

Is the answer really just finding somewhere to plug it in?

paul_b
21st July 2006, 05:18 PM
If you have the rpm file, try

rpm -iv [nameofrpm]

and see if that works, if it doesn't post the output

Jongi
21st July 2006, 05:20 PM
Being pedantic - but isn't FC5 Bordeaux?

rappermas
21st July 2006, 06:57 PM
Yes,

FC4 is Stentz and FC5 is Bordeaux. I'm running both and the easiest way to install MySQL is to pick it when you're actually installing the system. If not, go to Add/Remove Programs. Need to try this out...

Yup, just tried it on my Stentz (FC4) machine, which doesn't have internet hooked up yet and I went to Add/Remove Programs. Under Servers, you can choose to install MySQL database. Then, to start it... man, I'm forgetting this from disuse, have to go try it out...

ah yes

sudo /etc/init.d/mysqld start
and to stop it

sudo /etc/init.d/mysqld stop

take note that from there, you can start a ton of services, like httpd, etc

Robyn
21st July 2006, 07:31 PM
I'm pretty sure on on bordeaux so i must be on 5. guess that's good to know. Anyways, I thought I DID select it when installing, i checked off "developer tools" or whatever but I can't find it on there. If i go to add/remove programs it just says i can't retrieve software information.

and in response to paul:
it just say no such file or directory. Even when I'm totally in the directory pointing at the file.

rappermas
21st July 2006, 08:58 PM
Yeah, developer tools doesn't have MySQL. It will have things like Eclipse and programming things. MySQL is under the server section. Just pop in your installation media and go to Add/Remove Programs, you should find it there after a little scrolling around.

u-noneinc-s
21st July 2006, 09:46 PM
When you install with rpm -i, you need to provide the path to the file (or be in that path) so if your file is saved to the desktop you would do rpm -i /home/yourusername/desktop/filename.rpm. Same for yum localinstall. It would be yum localinstall /home/yourusername/desktop/filename (don't add the .rpm).
Also, rpm and yum need to be run as root.