PDA

View Full Version : installation problems



1mornewbee
19th July 2006, 03:07 AM
What's missing that marlin-0.9 won't install

[root@localhost marlin-0.9]# ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for perl... /usr/bin/perl
checking for XML::Parser... ok
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.
[root@localhost marlin-0.9]# make
make: *** No targets specified and no makefile found. Stop.
[root@localhost marlin-0.9]# make
make: *** No targets specified and no makefile found. Stop.
[root@localhost marlin-0.9]# ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for perl... /usr/bin/perl
checking for XML::Parser... ok
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.

marko
19th July 2006, 03:44 AM
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.

The above meant gcc (the gnu c compiler) that marlin was looking for
was not on your path. Most likely gcc wasn't installed at all
(the other possibility is that /usr/bin isn't included on your path
but it's so standard that it surely is).

you can install it via yum with:

yum install gcc

Mark

1mornewbee
19th July 2006, 05:16 AM
[root@localhost me]# yum install gcc
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
livna [1/7]
flash [2/7]
core [3/7]
jpackage-fedora [4/7]
jpackage-generic [5/7]
extras [6/7]
updates [7/7]
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for gcc to pack into transaction set.
gcc-4.1.1-1.fc5.i386.rpm 100% |=========================| 40 kB 00:11
---> Package gcc.i386 0:4.1.1-1.fc5 set to be updated
--> Running transaction check
--> Processing Dependency: libgomp = 4.1.1-1.fc5 for package: gcc
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for libgomp to pack into transaction set.
libgomp-4.1.1-1.fc5.i386. 100% |=========================| 28 kB 00:07
---> Package libgomp.i386 0:4.1.1-1.fc5 set to be updated
--> Running transaction check

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Installing:
gcc i386 4.1.1-1.fc5 updates 4.6 M
Installing for dependencies:
libgomp i386 4.1.1-1.fc5 updates 48 k

Transaction Summary
================================================== ===========================
Install 2 Package(s)
Update 0 Package(s)
Remove 0 Package(s)
Total download size: 4.7 M
Is this ok [y/N]: y
Downloading Packages:
(1/2): gcc-4.1.1-1.fc5.i3 100% |=========================| 4.6 MB 22:41
(2/2): libgomp-4.1.1-1.fc 100% |=========================| 48 kB 00:16
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing: libgomp ######################### [1/2]
Installing: gcc ######################### [2/2]

Installed: gcc.i386 0:4.1.1-1.fc5
Dependency Installed: libgomp.i386 0:4.1.1-1.fc5
Complete!
[root@localhost me]# cd marlin-0.9
[root@localhost marlin-0.9]# ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for perl... /usr/bin/perl
checking for XML::Parser... ok
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking for g++... no
checking for c++... no
checking for gpp... no
checking for aCC... no
checking for CC... no
checking for cxx... no
checking for cc++... no
checking for cl... no
checking for FCC... no
checking for KCC... no
checking for RCC... no
checking for xlC_r... no
checking for xlC... no
checking whether we are using the GNU C++ compiler... no
checking whether g++ accepts -g... no
checking dependency style of g++... none
checking for library containing strerror... none required
checking for a BSD-compatible install... /usr/bin/install -c
checking whether ln -s works... yes
checking whether make sets $(MAKE)... (cached) yes
checking how to run the C preprocessor... gcc -E
checking for egrep... grep -E
checking whether gcc needs -traditional... no
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for a sed that does not truncate output... /bin/sed
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking how to recognise dependent libraries... pass_all
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking how to run the C++ preprocessor... /lib/cpp
configure: error: C++ preprocessor "/lib/cpp" fails sanity check
See `config.log' for more details.
[root@localhost marlin-0.9]# make
make: *** No targets specified and no makefile found. Stop.
[root@localhost marlin-0.9]#

The yum install gcc went well, but marlin-0.9 still does'nt take

(configure: error: C++ preprocessor "/lib/cpp" fails sanity check
See `config.log' for more details.)
I have not got a (./configure) downloaded program to work yet. Other programs with different installs have worked.
Is there some software in the package manager that I need to install?

marko
19th July 2006, 05:34 AM
[root@localhost me]# yum install gcc
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
...................
Other programs with different installs have worked.
Is there some software in the package manager that I need to install?


To get the development stuff properly setup, it would probably be best to
use yumex's groupinstall/update:


[root@localhost] # yumex &

then select the Groups icon on the bottom left,
go in the Development > section and review what's in
Development Tools and Development Libraries,
and update install what you need (I bet it shows
gcc is already installed but that you need some
tools)
Mark

1mornewbee
19th July 2006, 06:06 AM
[root@localhost me]# yumex &
[1] 5783
[root@localhost me]# bash: yumex: command not found
That did not work. Thanks Mark, let's keep plugin away. I
woulld like to get this install to work. Then I would be able to do other installs.

1mornewbee
19th July 2006, 06:09 AM
[root@localhost me]# yumex &
[1] 5783
[root@localhost me]# bash: yumex: command not found
That did not work. Thanks Mark, let's keep plugin away. I
woulld like to get this install to work. Then I would be able to do other installs. The O.S. is Fedora 5

marko
19th July 2006, 06:40 AM
You just don't have yumex installed, it's an optional front end program to yum,
you can install it easily by running:

yum install yumex

It has some nice features like it's easier to install software groups
since it's graphical.

Either that the "not found" error is due to it not being installed
or yumex is not on your path, try as the root user:

/usr/bin/yumex

if it was a path issue, adding the /usr/bin to the front would work.

BTW, another way to confirm if a particular package is installed is
to run for example:

rpm -q yumex

if it replies with a package name then it's installed, like on my PC:

{07/19 1:38am}[5] rpm -q yumex
yumex-1.0.2-1.0.fc5


Mark

markkuk
19th July 2006, 08:07 AM
checking for g++... no
checking for c++... no
checking for gpp... no
checking for aCC... no
checking for CC... no
checking for cxx... no
checking for cc++... no
checking for cl... no
checking for FCC... no
checking for KCC... no
checking for RCC... no
checking for xlC_r... no
checking for xlC... no
checking whether we are using the GNU C++ compiler... no

You need the C++ compiler:
yum install gcc-c++

1mornewbee
19th July 2006, 05:01 PM
*** The pkg-config script could not be found. Make sure it is
*** in your path, or set the PKG_CONFIG environment variable
*** to the full path to pkg-config.
*** Or see http://www.freedesktop.org/software/pkgconfig to get pkg-config.
configure: error: Library requirements (glib-2.0 >= 2.4.0 gmodule-2.0 >= 2.4.0 gthread-2.0 >= 2.4.0 libgnome-2.0 >= 2.6.0 gnome-vfs-module-2.0 >= 2.6.0 gstreamer-0.8 >= 0.8.4 gstreamer-libs-0.8 >= 0.8.4) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
[root@localhost me]# rpm -q yumex
yumex-1.0.2-1.0.fc5
I installed gcc-c++
The path don't seem to be right. I went to the web site that the software refurred me to and was able to install the pkg-config software. marlin-0.9 still won't install
http://www.freedesktop.org/software/pkgconfig to get pkg-config
Now this is what I get.
checking for architecture specific defines... has libstdc++ hack
checking for pkg-config... /usr/local/bin/pkg-config
checking for glib-2.0 >= 2.4.0 gmodule-2.0 >= 2.4.0 gthread-2.0 >= 2.4.0 libgnome-2.0 >= 2.6.0 gnome-vfs-module-2.0 >= 2.6.0 gstreamer-0.8 >= 0.8.4 gstreamer-libs-0.8 >= 0.8.4... Package glib-2.0 was not found in the pkg-config search path. Perhaps you should add the directo ry containing `glib-2.0.pc' to the PKG_CONFIG_PATH environment variable No packa ge 'glib-2.0' found Package gmodule-2.0 was not found in the pkg-config search p ath. Perhaps you should add the directory containing `gmodule-2.0.pc' to the PKG _CONFIG_PATH environment variable No package 'gmodule-2.0' found Package gthread -2.0 was not found in the pkg-config search path. Perhaps you should add the dir ectory containing `gthread-2.0.pc' to the PKG_CONFIG_PATH environment variable N o package 'gthread-2.0' found Package libgnome-2.0 was not found in the pkg-conf ig search path. Perhaps you should add the directory containing `libgnome-2.0.pc ' to the PKG_CONFIG_PATH environment variable No package 'libgnome-2.0' found Pa ckage gnome-vfs-module-2.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `gnome-vfs-module-2.0.pc' to the PKG_CON FIG_PATH environment variable No package 'gnome-vfs-module-2.0' found Package gs treamer-0.8 was not found in the pkg-config search path. Perhaps you should add the directory containing `gstreamer-0.8.pc' to the PKG_CONFIG_PATH environment v ariable No package 'gstreamer-0.8' found Package gstreamer-libs-0.8 was not foun d in the pkg-config search path. Perhaps you should add the directory containing `gstreamer-libs-0.8.pc' to the PKG_CONFIG_PATH environment variable No package 'gstreamer-libs-0.8' found
configure: error: Library requirements (glib-2.0 >= 2.4.0 gmodule-2.0 >= 2.4.0 gthread-2.0 >= 2.4.0 libgnome-2.0 >= 2.6.0 gnome-vfs-modul e-2.0 >= 2.6.0 gstreamer-0.8 >= 0.8.4 gstreamer-libs- 0.8 >= 0.8.4) not met; consider adjusting the PKG_CONFIG_PATH environment variab le if your libraries are in a nonstandard prefix so pkg-config can find them
How do I adjust the pkg_config_path.
I'm ready to give up these commands are beyond me :(

multescugeorge@
19th July 2006, 05:21 PM
Easyest thing i can think of:
Open the menu, go to System->Add remove programs
A "Package Management" tool should open, there locate
"Development"
Then select:
Development Libraries
Development tools
Kde software development (and/or GNOME software development if you use gnome, i don't)
Legacy software development
Ruby
X Software development
Those ought to give a good compiler chain to compile everything that moves in the Linux world.
I'm preaty sure this package manager also connects to the net, and downloads the proper versions, not sure tho.

1mornewbee
20th July 2006, 05:19 AM
I went to package manager and did what you said the download did work it took a long time. 32 of 45 packages.
tried the (./configure) again everything goes great till it gets to pkg-config
configure: error: Library requirements (glib-2.0 >= 2.4.0 gmodule-2.0 >= 2.4.0 gthread-2.0 >= 2.4.0 libgnome-2.0 >= 2.6.0 gnome-vfs-modul e-2.0 >= 2.6.0 gstreamer-0.8 >= 0.8.4 gstreamer-libs- 0.8 >= 0.8.4) not met; consider adjusting the PKG_CONFIG_PATH environment variab le if your libraries are in a nonstandard prefix so pkg-config can find them.
[root@localhost marlin-0.9]# make
make: *** No targets specified and no makefile found. Stop.


Open the menu, go to System->Add remove programs
A "Package Management" tool should open, there locate
"Development"
Then select:
Development Libraries
Development tools
Kde software development (and/or GNOME software development if you use gnome, i don't)
Legacy software development
Ruby
X Software development

multescugeorge@
20th July 2006, 06:30 AM
I did a little research, and i found that "marlin" is a GNOME application, so it requires Gnome window manager and some "Gnome development" tools. You can use the package manager to install the missing libraries.

markkuk
20th July 2006, 10:14 AM
configure: error: Library requirements (glib-2.0 >= 2.4.0 gmodule-2.0 >= 2.4.0 gthread-2.0 >= 2.4.0 libgnome-2.0 >= 2.6.0 gnome-vfs-modul e-2.0 >= 2.6.0 gstreamer-0.8 >= 0.8.4 gstreamer-libs- 0.8 >= 0.8.4) not met;
You need to install the glib2-devel, libgnome-devel, gnome-vfs2-devel, gstreamer08-devel and gstreamer08-plugins-devel packages.

1mornewbee
20th July 2006, 05:17 PM
I did (yum install) on all those programs and it either installed them or updated them. marlin still won't install same problem.
consider adjusting the PKG_CONFIG_PATH environment variab le if your libraries are in a nonstandard prefix so pkg-config can find them.
I think I will just give in for now.........
TO EVERYONE
Thanks for all the help