PDA

View Full Version : Samba, rebooting, and /etc/init.d/smb restart



notmyrealemail
18th July 2006, 11:32 AM
[Jordan@BaGwa ~]$ su
Password:
[root@BaGwa Jordan]# /etc/init.d/smb restart
Shutting down SMB services: [FAILED]
Shutting down NMB services: [FAILED]
Starting SMB services: [ OK ]
Starting NMB services: [ OK ]
[root@BaGwa Jordan]# /etc/init.d/smb restart
Shutting down SMB services: [ OK ]
Shutting down NMB services: [ OK ]
Starting SMB services: [ OK ]
Starting NMB services: [ OK ]
[root@BaGwa Jordan]#

Every time I reboot, i need to restat samba to see myself in network neighborhood. wtf would cause this?

pjfg
18th July 2006, 12:59 PM
Run the command "testparm" to check your samba configuration.

notmyrealemail
19th July 2006, 04:05 AM
[root@BaGwa ~]# cd /etc/samba
[root@BaGwa samba]# testparm
Load smb config files from /etc/samba/smb.conf
Processing section "[homes]"
Processing section "[printers]"
Processing section "[share]"
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

[global]
workgroup = DARK_SIDE
server string = Samba Server
username map = /etc/samba/smbusers
log file = /var/log/samba/%m.log
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
printcap name = /etc/printcap
dns proxy = No
cups options = raw

[homes]
comment = Home Directories
read only = No
browseable = No

[printers]
comment = All Printers
path = /var/spool/samba
printable = Yes
browseable = No

[share]
path = /home/share
read only = No
create mask = 0777
guest ok = Yes
[root@BaGwa samba]#

notmyrealemail
19th July 2006, 04:17 AM
I guess Ill try before I restart samba. I would post that now but like an idiot i set a remote reboot command not thinking that grub defaulted to MCE. Of course, I relized as soon as I got the shutdown message.