PDA

View Full Version : Frequent hang in bonobo-activation-server



rhasselbaum
17th July 2006, 09:53 PM
Hi. I've been running FC5 for a while now and everything has been fine. But occassionally over the last few days, when I try to launch a GNOME app (e.g. Nautilus, Terminal, etc.), CPU utilization suddenly jumps to 50% on my dual-core box and stays there. The app doesn't open.

If I have a terminal window open, I can run top and I see that bonobo-activation-server has the CPU totally pegged. If I kill it and try launching the app again, it works fine. This happens about three or four times a day. Very annoying!

Except for regular updates via YUM (including Kernel), I haven't changed anything on my system lately. Has anyone seen this before?

Thanks.

newfc2user
18th July 2006, 04:28 AM
I have precisely the same problem. I have a suspicion that it is due to the mail-notification applet that I am using. Are you using it as well?

rhasselbaum
18th July 2006, 02:20 PM
No, I'm not.

It's gotten to the point where I'm crossing my fingers every time I open an application. :( I do think it was caused by some recent update in YUM because I haven't installed anything new. And I've seen other recent forum posts that sound similar, but no solutions.

rhasselbaum
20th July 2006, 02:13 PM
This might be a coincidence, but I upgraded a beta copy of VMWare Server to the GA version on that box a day and a half ago. Since then, I have not seen the problem return. I will post back if it does.

rhasselbaum
24th July 2006, 02:29 PM
No, it was a coincidence. Hang is still happening.

No one else sees this?

newfc2user
24th July 2006, 02:43 PM
I am in the same boat as you. Happens to me all the time. If I kill the bonobo process, my file dialog pops up. I don't have to re-start my application. So for now, I can live with it.
I run FC5 on my laptop. A trend I have noticed is that the problem doesn't seem to occur with a fresh boot. It happens mostly after a suspend/resume cycle. Unfortunately, it is not very repetitive to pin out an exact sequence of events, so I haven't submitted a bug report nor have I added to a couple of existing ones around this issue.

rhasselbaum
8th August 2006, 05:30 PM
I performed a cold reboot (power down) and the problem has not returned since then. That was a few days ago.

I'm not using a laptop, so I never suspend/resume.

cheerio158
9th August 2006, 01:47 AM
I have been having the same annoying problem with my work FC5 laptop. When it is connected to the workplace network, all is fine. When I take it home, to a client site or from a hotel Internet connection when I am travelling, I have this problem. I keep a terminal screen running top so I can kill them.

I think that it has something to do with networking, perhaps caused be remote drives "mounted" by the Places dialogue that are not available because I not on the usual workplace network.

Further, this is a FC5 problem - never happened in FC3, FC4. My home FC5 desktop never has this problem.

Still investigating ... :confused:

rhasselbaum
9th August 2006, 02:28 PM
I think that it has something to do with networking, perhaps caused be remote drives "mounted" by the Places dialogue that are not available because I not on the usual workplace network.
If that's true, then there's more than one cause, because none of what you described applies in my case. I'm using a desktop that is always connected to the same network. The next logical step would be to debug this, but I can't reproduce it now.

BiQuaternion
21st October 2006, 07:19 PM
Hi to everyone,

yes, this bonobo annoying me as well - it takes 88% CPU because the
bonobo-activation-server --ac-activate
is launched doubled every time !! . I noticed it after upgrading libs and yum. Network deactivation does not stop it. Only killing helps so far.

rhasselbaum
21st October 2006, 08:45 PM
Try cold booting. I have the problem very rarely now. And when I do, cold booting seems to make it go away for a long time (weeks).

BiQuaternion
22nd October 2006, 06:10 AM
This a bug that has to be reoprted. Someone in this forum already fixed it.
This solution works good: in the Sytem sub menu, the support of additional assistance ( for impaired/disabled) has to be disabled.
bonobo-activation-server will not bother again