PDA

View Full Version : Problem Booting FC5_2145 or 2157 on AMD64



SStead
17th July 2006, 05:37 PM
Running Dual Opteron 850s in K8n-dl with SATA Raid 0 (hardware), 3GB memory witn x86_64 kernel FC5_2133 is running. Stable, fast and reliable.

Using PUP, updated kernel to 2145 It hung at nash 5.0.32. NO trap, no other messages. When 2157 arrived, same result. Able to use GRUB at boot to boot 2133 kernel and system is back up.

Any ideas?
Thank you

LinuxHippy
17th July 2006, 06:35 PM
mine boots fine when installed with the x86_64 DVD iso....is that what you used? I'm using an Athelon AMD 64 pc.

Thetargos
18th July 2006, 02:33 AM
SStead, if you have the opportunity, try booting the system with one of the conflicting kernels, but at the grub prompt, use 'e' on its menentry and then again in the big kernel line and remove 'quiet' from the kernel command line. Maybe a more explainatory message goes by whithout you noticing it... You should see anything suspicious though with the 2145, as it was up to 2157 that quiet was broken. To speak the truth I have not used the last three kernel updates from Fedora, as I'm using a custom built kernel.

boknoy
19th July 2006, 02:51 PM
I have a AMD X2 3800 with an Asus a8n-sli deluxe motherboard running 4 sata hardisks on raid 0 configuration. I've just yum updated from a fresh install.

I have the same problem wherethe linux kernel cannot boot with the new 2157 smp kernel. Using the default kernel from the install dvd works ok.

My system however is complaining that it can't see or mount the logical disk (/dev/mapper/XXXXX) where the root and swap file system is located.

Maybe the nv_raid driver is no longer built into the new kernel or the nv_raid driver is not being loaded? I don't know if this is the case as I'm to lazy right now to try and download the kernel source rpm and try to compile a new kernel.

Thetargos
19th July 2006, 03:49 PM
Why don't you download and install one of the 2.6.16 kernels from download.fedora.redhat.com/.../updates?

boknoy
20th July 2006, 01:45 AM
I just installed the 2133 kernel and its the same result. Made a stupid mistake of doing a kernel upgrade instead of a separate install and so my system is now totally unbootable.

Can someone instruct me how I can mount or access the rpms in the installation dvd when I boot into linux rescue mode from the dvd so I could install the default kernel?

I also just realize that this is not a AMD64 problem but rather a hardware problem with the update kernel with regards to sata raid.

Thetargos
20th July 2006, 02:48 PM
Go into rescue mode, make sure you have the Anaconda see your installation. Then just mount the DVD, copy over to some directory on your mounted system the RPM for the kernel, then chroot mnt/sysimage, and install said RPM. Reboot, and update to the latest 2.6.16, AVOID 2.6.17 as apparently its included libata is not compatible with your hardware!!

bl117
6th August 2006, 05:47 AM
I have tried everything i've seen posted in the forums to fix this problem as i need to use the 2.6.17 kernel for xgl. i am using a single pata ide drive installed on the nvidia controller. 3 partitions exist on this drive. boot (ext2), swap, and / (ext3). any ideas?

bl117
6th August 2006, 06:25 AM
finally found it!! for anyone having problems try this thread.....

http://www.fedoraforum.org/forum/showthread.php?t=114158&page=2&pp=15