PDA

View Full Version : Wine packaging mistake?



Thetargos
15th July 2006, 05:40 AM
I certainly can't believe that Wine suddenly requires all the other packages to be installed in order to be operational, I mean, if you install wine fresh with pirut, it will want to install *every* wine package... it was not the case for previous releases, and it certainly should not be the case for 0.9.17... In any case, this is most likely a problem with Requires declarations in the .spec, and these should be corrected... I mean, what's the point in making it modular, if every single package will be installed? In that case, isn't it better to leave it monolithic?

Sorry for ranting, a bugzilla entry will soon be added, just had to work on the anger first.

Thetargos
15th July 2006, 05:52 AM
There, here (https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=198969) is the bugzilla for this particular issue... I also noticed that the 0.9.15 package (last to actually yield a reasonably good performance in some apps I care about has been removed, pitty)