PDA

View Full Version : ATI X300 OpenGL Issue



ShadyEnigma15
14th July 2006, 09:49 PM
Okay... so I've installed the fglrx drivers for my ATI video card, and when I run fglrxinfo i get the following output:

display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: MOBILITY RADEON X300 Generic
OpenGL version string: 2.0.5879 (8.26.18)

now from what i've read... this indicates OpenGL is installed jsut fine?

However, when i run some applications which rely on OpenGL i get messages telling me OpenGl is installed incorrectly etc...

For example Matlab 7.0 provides the following ouput: "Warning Could Not Accept OpenGL Library"
Games such as SuperTux also grey out the OpenGl video option...
And the KComet OpenGL screensaver I have runs VERY slowly.

Any ideas on what's going on?

Gul Dukat
14th July 2006, 09:53 PM
When you type the following command glxinfo | grep direct in a konsole, what does it say?

ShadyEnigma15
14th July 2006, 10:00 PM
i get "yes"

is there maybe some sort of small program that can directly tell me or show me?

gundark
14th July 2006, 10:13 PM
um, you could try glxgears if you have it installed, or search the forum on how to install them, they show you framerates and some pretty gears, I think they test glx, that would be silly to name them that if they didn't

ShadyEnigma15
14th July 2006, 10:17 PM
Result of Glxgears:
10560 frames in 5.0 seconds = 2111.912 FPS
10546 frames in 5.0 seconds = 2109.052 FPS
10548 frames in 5.0 seconds = 2109.561 FPS
10549 frames in 5.0 seconds = 2109.743 FPS

I guess these are good results? FPS seems high...


umm.. excuse my lack of knowledge on this whole thing... but what exactly is Glx and why are we testing Glx and not OpenGl? or are they the same thing?

gundark
14th July 2006, 10:28 PM
I am still pretty knew, I just know I had allot of problems getting all of that to run and when I started out it gave me 200fps so I offered it as a sugested place to start, see if his prolems were in anyway related to mine, but I think I may have gotten this one off track.

ShadyEnigma15
14th July 2006, 10:36 PM
hmm...

anyone else have any ideas on what i could do to test?

gundark
14th July 2006, 10:53 PM
http://www.novell.com/documentation/suse91/suselinux-adminguide/html/ch04s03.html
this has got some stuff related to testing opengl, could help