PDA

View Full Version : FC5 not detecting RAID in HP Proliant DL380 G4



jchrisos
14th July 2006, 03:28 PM
here's output of "df"

Filesystem 1K-blocks Used Available Use% Mounted on
/dev/cciss!c0d0p3 267553232 158337856 95405100 63% /
/dev/cciss/c0d0p1 101086 9642 86225 11% /boot
tmpfs 2502244 0 2502244 0% /dev/shm

What is that exclamation point doing in /dev/cciss!/c0d0p3???

Here's another interesting thing. When I first installed Fedora, I manually set up partitions using three filesystems. I got errors booting up about it not having write access to the root partition. I had to boot from CD using "linux rescue", disable fsck by adding a "0 0" at the end of the line in fstab and also disable SELinux. It then rebooted without any problems.

Next, I installed using the default partitions and did not edit them. You know, the logical volumes or what not. It started up without any errors. No complaints about not having write access.

Next, I went back and specified my three partitions like I initially did. Set up a swap partition, set up a /boot partition and a / partition. Same errors about not having write access as before.

Interestingly enough, there were no exclamation points when running "df" using the logical volumes. But when I specify three partitions manually, it shows up with an exclamation point rather than a slash.

Everything seems to be working okay. Othar than our Oracle database having to wait on the disk a lot.

Why is my disk drive showing up with a slash in it? Should I be concerned? We have other servers running RHEL and SLES and everything is fine. Why did I need to disable SELinux and disable fsck?

If it means anything, this box has the "!" showing up and my backup exec linux agent doesnt work. On my other fedora box, there is no "!" and mybackups work fine. Since Veritas/Symantec doesnt support Fedora, they wont help.

Thanks in advance,

Jim

pparks1
14th July 2006, 05:41 PM
I use CentOS 4.3 on HP Proliant DL380 Gen4's and that is working great for me. I haven't noticed the ! on my CentOS systems and I haven't tried Fedora yet on my servers.

jchrisos
14th July 2006, 09:22 PM
I use CentOS 4.3 on HP Proliant DL380 Gen4's and that is working great for me. I haven't noticed the ! on my CentOS systems and I haven't tried Fedora yet on my servers.


If you attempt to install FC5 and if you can afford to play around, try not using the default disk configuration (i.e. dont use the logical volumes). I set up a /boot, / and swap using ext3. Give it a shot and see how it sees your drive. Keep in mind I'm using the Compaq Smart Array 6i and have one logical drive in RAID 5 set up.

Jim

jchrisos
14th July 2006, 09:29 PM
Does this help anyone out? There's a folder called cciss, then there are also devices named cciss!...

[root@machine dev]# ls -al /dev/
total 8
drwxr-xr-x 13 root root 3640 Jul 12 13:51 .
drwxr-xr-x 26 root root 4096 Jul 12 08:32 ..
drwxr-xr-x 3 root root 60 Jul 12 08:31 bus
drwxr-xr-x 2 root root 120 Jul 12 08:31 cciss
brwx------ 1 root root 104, 0 Jul 12 03:31 cciss!c0d0
brwx------ 1 root root 104, 1 Jul 12 03:31 cciss!c0d0p1
brwx------ 1 root root 104, 2 Jul 12 03:31 cciss!c0d0p2
brwx------ 1 root root 104, 3 Jul 12 03:31 cciss!c0d0p3
lrwxrwxrwx 1 root root 3 Jul 12 08:31 cdrom -> hda

jchrisos
18th July 2006, 04:32 PM
Any suggestions anyone?

boba_fett
27th July 2006, 04:24 PM
I seem to have the same kind of problem.

After installing FC5 on my Proliant ML350 with a Smart Array 431 controler (without any problem), I seem to get stuck during it's first (inital) boot. It ends with the following remark:

Checking filesystems
fsck.ext3: Permission denied while trying to open /dev/ida!c0d0p2
You must have r/w access to the filesystem or be root

First of all, while using CentOS4.3 on it, I never saw this problem/message.
Secondly, if I enter the shell and specify that partition while checking it for error as /dev/ida/c0d0p2, it works flawless.

Is the "0 0" option the only workaround? :(
Or is this a "bug" in FC5?

boba_fett
27th July 2006, 04:51 PM
Entering runlevel 1 or "emergency¨ does not help.
The partitions are mounted "read-only".

Booting from CD doesn't work either (with the boot.iso burned as a installation cd).

:( :(

jchrisos
27th July 2006, 05:29 PM
Have you since edited /etc/fstab and disabled SELinux? I ran the actual FC5 boot disk, and at the prompt ran "linux rescue".

Once I did that, I was able to boot normally (minus the ! showing up).

boba_fett
27th July 2006, 08:14 PM
Seems to be related to SELinux.
I used the first CentOS4.3 installation CD to boot into rescue mode (no SELinux) and managed to edit /etc/fstab (the "0 0" option). After that, booting went flawless. And it made sense to me: I noticed a remark during the initial boot concerning SELinux and /dev/ida/c0d0p2, the same one the system crashed on (c0d0p2 is the / partition).

After the boot, I changed fstab back into the original format (with the "1 1" and "1 2" where used) and now all works fine (because I disabled SELinux).

By default, FC5 boots the first time with SELinux enabled (previous versions did not, like CentOS4.3).
Perhaps would it be wise to have SELinux disabled until the firstboot sequence it started (use it to enable/disable it as it was before) ???

Note: the / partition is shown now without the !
Other partitions arent ..... ??

Anyway, thanks for helping!

jchrisos
2nd August 2006, 04:34 PM
Seems to be related to SELinux.
I used the first CentOS4.3 installation CD to boot into rescue mode (no SELinux) and managed to edit /etc/fstab (the "0 0" option). After that, booting went flawless. And it made sense to me: I noticed a remark during the initial boot concerning SELinux and /dev/ida/c0d0p2, the same one the system crashed on (c0d0p2 is the / partition).

After the boot, I changed fstab back into the original format (with the "1 1" and "1 2" where used) and now all works fine (because I disabled SELinux).

By default, FC5 boots the first time with SELinux enabled (previous versions did not, like CentOS4.3).
Perhaps would it be wise to have SELinux disabled until the firstboot sequence it started (use it to enable/disable it as it was before) ???

Note: the / partition is shown now without the !
Other partitions arent ..... ??

Anyway, thanks for helping!

I edited my /etc/fstab back to include the "1 2" but still have the ! showing up. You sure it was that and not something else that fixed your problem? I still have SELinux disabled.

boba_fett
20th August 2006, 07:33 PM
Well, there is a bug at Bugzilla about it (link (https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=200510)).

As far as I know, SELinux gets confused (triggered by something unknown) and prevents a proper booting.
Editing the numbers in /etc/fstab does allow the system to boot up. But only if you disable SELinux will allow you to continue booting it.

Yes, my system too has the ! instead of the / where it should be.
No idea how to solve that one (also noted in the Bugzilla report).

jchrisos
21st August 2006, 01:58 PM
Thanks for the info!!!