PDA

View Full Version : Black and white TV-out on a Geforce 7300GS



tonyingesson
13th July 2006, 06:50 PM
I recently bought a new computer with a new graphics card, an ASUS Geforce 7300GS. Since tv-out worked out-of-the-box for me with my old Geforce Ti4200 card, I thought it would be breeze to get it working again. Indeed it was, I enabled the dual head option in the Display settings, but the image is black and white. I thought it might be due to NTSC output to my PAL TV so I tried the Option "TVStandard" "PAL-G" in the Device section in xorg.conf. No change whatsoever.

Then I noticed that the TV-out is always active! It doesn't need any drivers, it shows everything from the second I boot till I turn the computer off.

So now I'm thinking, is there some kind of pre-set NTSC output coming from the card that overrides the PAL settings in the xorg.conf file? Can I somehow access the card bios? I've tried googling for that but had no success. Or is this caused by something else?

I'm using an S-video cable hooked up to a SCART adapter by the way.

Simon_6162
14th July 2006, 11:29 PM
On my ATI 9200se card I have a similar problem. The solution that I found was to only plug the tv out cable in after the computer has loaded the first bios screen. This stops the tv out being enabled by the card until xorg tells it to do so and fixed my colour problem.

tonyingesson
15th July 2006, 12:33 PM
Thanks for the tip, but unfortunately it didn't work. The thing I've noticed now is that I have the same problem in Windows as well. Could this be cable-related? The weird thing though is that I know that the cable works perfectly since I've used it with another graphics card just a few days ago.

Simon_6162
15th July 2006, 12:47 PM
My guess would be either the cable or the TV format.

If it is running in NTSC then you should be able to see that the pixcels on the TV look taler than for PAL if you look really close, so this might be one clue. I would assume that the section in the xorg.conf file would control this. Are you sure your TV standard is PAL-B ???

Are you putting the scart cable direct into the TV i.e no video inbetween, this avoids any macrovision effects. (I doubt it is this one tho!)

Finally try another cable.

Jongi
15th July 2006, 01:19 PM
I am suspecting an issue with te standard that the computer is telling the card to use as output eg it's outputing NTSC to a PAL TV

tonyingesson
15th July 2006, 01:19 PM
Well, I've tried using various PAL settings in both xorg.conf and in Windows. No change whatsoever. I'm not using a scart cable, I'm using an S-video cable connected to a scart adapter. I know the cable works as it should, as I stated before I last used it only a couple of days ago in another computer. Would it help to have an s-video to composite cable? I have no idea at this point...

Simon_6162
15th July 2006, 02:59 PM
Are you putting your s-video lead into an s-video socket ? As on some cards the connector looks like an s-video socket but has more pins. If you put an s-video into one of those you normally get a b+w signal out (and also bend some pins. ) I did this on an old matrox card. Switching to composite with the supplied adapter did fix it.

tonyingesson
15th July 2006, 04:16 PM
You're right! I just checked, that port is no S-video port, even though it looks a whole lot like one. The S-video cable fit though, no pins bent or anything. But there are too many holes. I'll just get an adapter for it and it should work. Thanks for the help!!

Jahova
23rd August 2007, 10:23 PM
Hi.

I have this same problem on my Geforce 6600 with nvidia driver. I am trying to use my TV as a second monitor for watching DVD's and stuff.

I am using the S-video to 'yellow video plug' adaptor that came WITH my video card. There should be no problems with my adapter plug being the wrong type. My TV sceen is all black and white... but only when X is running.

When I boot my computer, the TV works in color mode just fine. The BIOS splash screen dispays in color and even the grub screen is in color. It is only in X that it's black and white.

I tried Windows XP and it does the same thing. It is in color until I log in.

Can someone PLEASE post up how to change the NTSC thing to PAL anything. Please I desperatly need this soon. Is there anything at all I can do????????

Simon_6162
24th August 2007, 10:10 AM
Fedora edit /etc/X11/xorg.conf
you should have "TVStandard" option try setting that. also just google it this is a common question. (I only have ATI cards so can't really help you out.)

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Chaintech"
BoardName "nVidia GeForce 4 MX 440"
Option "RenderAccel" "1"
# TV Out Setup
Option "TVStandard" "PAL-I"
Option "TVOutFormat" "SVIDEO"
Option "TVOverScan" "0.6"
Option "ConnectedMonitor" "TV" # Add this if you're having problems
EndSection


Windows will be right click on your desktiop -> preferences -> what ever the end tab on the right is called (Display ?)-> advanced -> some where in there :) Sorry I don't have windows available to fill in the blanks.

Jahova
25th August 2007, 05:43 AM
Ok thanks.

I see something that may work. I will try some more.

I will post back after.

Fenan
28th August 2007, 04:06 PM
I finally got it !

I used the HDTV adapter cable I got with the 7300GS card to connect to the 9-pin socket.
http://www.ssrf.se/host/images/HDTV_adapter.jpg
(the 9-pin socket is very simular to the s-vid 4-pin connector, although it fits, you cant use the s-vid connector here)
http://www.ssrf.se/host/images/hdtvout.jpg http://www.ssrf.se/host/images/tv_in.jpg
I connected my yellow Composite cable to the GREEN socket on the adapter and the other end to the TV's yellow composite in socket.

My screen on the TV turned black-and-white.

Now the sollution:
In nVidia Geforce 7300 GS settings I pick nView Display Settings, clone, click 1b (TV monitor), click Device Settings >>, Select TV format, Advanced.
Here I chose '(Combination) N/PAL' and 'Composite Video-Out'

Now I got NO picture on the TV, so I switched the composite cable on the adapter from green to BLUE socket. And there.... COLOR TV!!

NOTE! There is a label on the adapter's cord saying:
Either use RED+GREEN+BLUE socket or
S-VID or
GREEN socket for composite

acutally you are able to use ONLY BLUE, but with S-VID and black-and-white screen :p

ttr738
12th November 2008, 04:27 PM
Fedora edit /etc/X11/xorg.conf

# TV Out Setup
Option "TVStandard" "PAL-I"
Option "TVOutFormat" "SVIDEO"
Option "TVOverScan" "0.6"
Option "ConnectedMonitor" "TV" # Add this if you're having problems
EndSection



Thankyou thankyou thankyou! After 3 days of trying to get my card to output to s-video, this sorted it!
Not with fedora - I'm on Ubuntu Interepid - but this still did the trick. Much appreciated!!