PDA

View Full Version : Can someone PLEASE help with BCM4318 and FC5 2.6.17 x64 2145...NONE of the posts work



DarkoD
13th July 2006, 01:11 AM
Hi all.

I know, there are quite a few posts about this card (and bcm43xx in general) and FC) and they sound simple to follow, but believe it or not, NONE of them work on my system out of whatever reason.

I'm getting really desparate now. Got this laptop 2 weeks ago and still can't make this stupid wireless to work. :(

I've tried everything I found on the posts.

I have Acer Ferrari 4005, with BCM4318 (at least reported as such), running FC5 2.6.17_2145 x64 version.

I even reinstalled the FC5 an hour ago just to make sure the system is "clean" of any mess I might have created during numerous tries to make this wireless work.

After the reinstall, I tried with bcm43xx-fwcutter and BCMWL564.sys from Acer website (64-bit Win driver). As per posts here. First of all ,I keep getting that message that the driver was created with wireless extension 20 while it will support only 19. Don't know if that is a problem but don't know how to avoid it anyway. I have also tried with ndiswrapper and wpa_supplicant. :( No joy either.

Anyone willing to lead me trough some troubleshooting or show me how to remove all of the above and try something specific???

Thanks to everybody in advance. I like the FC5 for a lot of things but I simply can't believe that connecting to basic broadband router is this impossible... :(

Cheers.
Darko.

LLS
13th July 2006, 01:22 AM
This guy usually gets it right, follow the details closely.
native
http://www.fedoraforum.org/forum/showthread.php?t=115572
ndiswrapper
http://www.fedoraforum.org/forum/showthread.php?t=100195

DarkoD
13th July 2006, 01:30 AM
Thanks for the good intentions LLS.

I can only say: BEEN THERE, DONE THAT. :)

And no, it doesn't work right in my case. :( In fact, the first link you suggested was the post I followed immediately after the recent reinstall, on clean system. Not working.

ppesci
13th July 2006, 02:17 AM
go to the HOWTO in this site,
http://forum.fedoraforum.org/forum/showthread.php?t=102697&highlight=bcm43xx

Follow instructions, it work for me.
BTW, there are a link for a driver that you can download.

Pietro Pesci Feltri

DarkoD
13th July 2006, 08:27 PM
Thanks ppesci.

I have seen that post before, and I just tried it once more. Everything goes without any error, however it doesn't work. :(

It might be a driver problem but I have tried all drivers suggested in posts here, the wl_apsta.o bcmwl5.sys and bcmwl564.sys. I don't know what else to try... :(

LLS
13th July 2006, 09:34 PM
Two other solutions I have seen one was to replace ndiswrapper ver1.5 with version 1.1 and the other, I know this post is for ubuntu or some other but do the conversion, it is a very good step by step that might give you a hint at a solution.

Steps:

sudo modprobe -r bcmwl5
sudo rmmod ndiswrapper
sudo apt-get remove ndiswrapper-utils
sudo rm -r /etc/ndiswrapper/
sudo rm -r /etc/modprobe.d/ndiswrapper

Install the kernel-headers for your kernel. If you don't know what kernel you are using, type:
uname -a
then using synaptic (or apt-get if you prefer, search for the kernel-header that matches your kernel.
then,
sudo apt-get install gcc-3.4

Copy the bcmwl5.inf and bcmwl5.sys files to your desktop, or some location that you know where it is.

(I actually needed to use the bcml5a.inf, which took some searching to figure out, take that into consideration..maybe download both and have them both ready. If when you do a ndiswrapper -l )

Go here and download/complile then install the 1.5 release of ndiswrapper
http://sourceforge.net/projects/ndiswrapper/
Download the 1.5 tarball
tar xvfz <file_name_here>
cd <file_dir>
sudo make
sudo make install

sudo ndiswrapper -i <dir_of_file>/bcmwl5.inf

ndiswrapper -l

This steps IS most important, check and make sure the result is something like:

Installed ndis drivers:
bcmwl5a driver present, hardware present

If it's not, you probably have the wrong driver, so don't waste any more time doing any other steps. It MUST say the above to work correctly. If you just tried the bcml5.inf and it didn't work you may need the bcml5a.inf driver. Always check this step, else you would be wasting your time and energy. Make sure the driver sees the device.

Then:

sudo ndiswrapper -m

Then:

sudo modprobe ndiswrapper

The next step is just as important as all the others, it wont work until you do it:

Go to the system, admin, networking, and enable, configure your wifi device and activate it. deactive your eth0 connection. (i'm assuming you just want to use the wifi..)

I think this last step is important because eth0 gets set by default Good luck!

DarkoD
13th July 2006, 09:46 PM
OK, got it working finally. Thanks for the efforts LLS.

I put more about my solution on http://forum.fedoraforum.org/forum/showthread.php?t=102697&page=6

It turned out there is really simple way, after wasting 2 weeks on it. :)

Working with no encryption at the moment but I have MAC filtering on the router so not worried much. At least I got it working. The next step will be WEP and maybe WPA.

Cheers.