View Full Version : networking VERY slow in FC2 test1

20th February 2004, 01:43 PM
With FC2 Test 1, my internet connection (or maybe it's just Mozilla?) is REALLY slow. Like 30 seconds or so just to load Google. I connect via cable modem through a d-link gateway. FC1 was always fast, and if I boot the same machine into another OS the speed is fine. Sometimes restarting the network (service network restart) seems to help a bit. I've done the ipv4_ecn bit that was mentioned on the Fedora mailing list; that let me connect to some sites, but the speed still sucks.

Anyone else seen this? Any suggestions for diagnosing/troubleshooting?


20th February 2004, 08:03 PM
Some quick suggestions:
1. Slow speed may be due to DNS problems. To diagnose use e.g
ping x.y.z.w to see roundtrip times without name resolution and then use
ping the.fullyqualified.domainname (where x.y.z.w is the IP address of fullyqualified.domain.name). If there's a significant difference then you've got a DNS problem.

2. You could have a MTU fragmentation problem. This is worht considering only after eliminating easier options and we'd have to use tcpdump to diagnose.

3. It's possible that there's an auto-negotiation of ethernet speed to the gateway failing. Check using
mii-diag on the interface.

That's all that I can think of off-hand.

21st February 2004, 06:50 PM
Looks like it could be DNS related. Pinging a hostname (www.google.com) takes several seconds to respond, but then the ping times are the same as pinging the IP address.

mii-tool reply looks ok too:

[root@localhost root]# mii-tool -v
eth0: negotiated 100baseTx-FD, link ok
product info: vendor 00:10:5a, model 0 rev 0
basic mode: autonegotiation enabled
basic status: autonegotiation complete, link ok
capabilities: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
advertising: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD flow-control
link partner: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD

I can do a sustained download at a pretty high speed - I was getting over 340Kps last night downloading from Sun, but it took about 5 minutes to get to the java download page.

My /etc/resolv.conf just has this:
search localdomain is the inward port on my cable router. nsswitch.conf has this:

hosts: files dns

And ya know what? I just removed the "files" from that line, since I'm not doing any /etc/hosts lookup, and it's looking a lot faster.

Maybe that's the fix. Speeds are fine when I reboot into another OS, so I really think (thought) it's something in my Linux config, not hardware or something upstream.

Even though the nsswitch.conf fix seems right, I'll send all this message, in case my troubleshooting steps may help someone else.

Thanks for the suggestions!

24th February 2004, 10:03 PM
Yet another reply to my own post....sigh. Not sure it's really resolved.

Checked my DNS settings on the other side of my dual-boot machine, and the DNS server is hardcoded to a "real" ip address...not the one that Linux gets from DHCP (which points to my DHCP server,

I changed the Linux side to match, no joy. So while it seems better, it's still nowhere near what it should be.

25th February 2004, 04:34 AM
One other possibility that occurs to me is that Explicit Congestion Notification is set. To check it:

sysctl -a | grep ecn if you do this as non-root it'll spew out some complaints, but at the bottom there'll be a line with
net.ipv4.tcp_ecn = 1 if ECN is flagged as "on" for the kernel. If it is then "turn it off" with either
/sbin/sysctl -w net.ipv4.tcp_ecn=0 or else use
echo "0" > /proc/sys/net/ipv4/tcp_ecn and then see if you still have the same problems. If that solves it then make the changes permanent in /etc/sysctl.conf

25th February 2004, 04:42 AM
Thanks....that was about the first thing I tried (that's what I meant in my original post about the "ecn thing"). It's set to 0, but it hasn't helped.

The nsswitch.conf change hasn't really made much difference either, and hardcoding the DNS values to what the other half of my dual boot machine says hasn't really either. My wife dipped into this Linux setup for the first time today, and her comment was "the internet is really slow...."

12th March 2004, 08:16 PM
Thought I'd follow up again with what may be the answer. It works, meaning that my DNS is fast again, but it may not be the real solution. In my troubleshooting I found that ipv6 was enabled on my network card, and it seemed to do funny things with my DNS lookups. So I asked on Red Hat's Fedora Test list how to disable ipv6. Here was one answer (since the obvious things I tried, documented in /etc/sysconfig/network-scripts/init.ipv6-global

In the file /etc/modprobe.conf, I had to add this line:

alias net-pf-10 off

Add that right after the "include /etc/modprobe.conf.dist" line. Reboot (maybe not necessary, but need to unload the ipv6 modules, and rmmod didn't work).

Now my DNS is fine. Hope that helps someone. Maybe it's a flaky config on my ISP's part? (comcast.net)

For a full discussion, see the Fedora Test List archive discussion starting here: http://www.redhat.com/archives/fedora-test-list/2004-March/msg00280.html

The thread is "disable ipv6?"


18th March 2004, 05:17 AM
Just a sidenote on this. I had the same problem in Core 1, and using the remedy posted by randy worked like a charm.

28th May 2004, 02:31 PM
Had the same probelm in FC 2, but your fix sorted it out nicely =)
I didn't have that 'include' line in my modprobe.conf though, so i put it on the last line of my modprobe.conf.dist
Anyway, works great now. Thanks a lot!

28th May 2004, 03:28 PM
One other thing....I found that without my D-Link router in the setup, the network flew, with or without the IPV6 change. So I upgraded the firmware on the router, and everything is good. I have a D-Link 614+ now running firmware 2.20. Someone else wrote me that they tried a more recent version of the firmware, but still had the slowness. So you might try upgrading your firmware if you have a similar setup.


31st May 2004, 04:15 PM
DNS resolution with FC1 was snappy.
With FC2, when using FireFox, it is very slow.
IPv6 is disabled.
a ping name resolution is instant.
Any ideas on how FireFox on FC2 might do use DNS in a different way that Ping?

1st June 2004, 12:02 PM
If it helps anyone else. I deleted the Wireless card completely, then readded and DNS is now responsive under FireFox. I have no idea what could have changed though.